1

I reinstalled drush 8.0.0 with the command $ composer global require drush/drush:8.* but I get this message that keeps coming up.

count (): Parameter must be an array or an object that implements Countable Table.php : 789 [warning]

Drush's path: "C:\Users\Admin\vendor\drush\drush\drush" which is included in the environment variable. When I launch the command $ drush status I get this message?

$ drush status
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
count(): Parameter must be an array or an object that implements Countable Table.php:789                                    [warning]
 Drupal version                  :  8.8.1
 Site URI                        :  http://default
 Database driver                 :  mysql
 Database hostname               :  localhost
 Database port                   :  3306
 Database username               :  root
 Database name                   :  portod8_shop11
 Drupal bootstrap                :  Successful
 Drupal user                     :
 Default theme                   :  porto
 Administration theme            :  seven
 PHP configuration               :  C:\\xampp\\php\\php.ini
 PHP OS                          :  WINNT
 Drush script                    :  C:\\Users\\Admin\\vendor\\drush\\drush\\drush
 Drush version                   :  8.0.0
 Drush temp directory            :  C:\\Users\\Admin\\AppData\\Local\\Temp
 Drush configuration             :
 Drush alias files               :
 Install profile                 :  standard
 Drupal root                     :  C:\\xampp\\htdocs\\demo_shop11
 Site path                       :  sites/default
 File directory path             :  sites/default/files
 Temporary file directory path   :  /tmp
 Sync config path                :  sites/default/files/config_ipyhRF_n6qHfOKI-3QOzVHJAJ6B-uvjnetxouS9C6G2aam9h8D4rS-i6vf9travuOIG34F0
                                    tcg/sync
  • 4
    I'm voting to close this question as off-topic because it's a known bug and you need to upgrade Drush to fix it. – leymannx Jan 2 at 20:41
  • 1
    Drush 8 actually is at 8.3.2 but your $ drush status is telling you your Drush version is 8.0.0. Maybe you need to fix the executable. Meaning your current $ drush command is referring to another Drush installed differently? – leymannx Jan 2 at 20:45
  • 2
    Thanks for this important info leymannx! I uninstalled everything and reinstalled Composer and Drush. Now I have Composer V1.9.1 and Drush V8.3.2 everything seems to be working perfectly. A big thank you leymannx! I was also on the Drupal France forum on the Slack forum and no one found the reason for my problem. Thank you to everyone on the 'DRUPAL ANSWERS' forum – looga Jan 4 at 11:34
  • Another comment: You should not install Drush 8 using composer global require .... Please read docs.drush.org/en/8.x/install And since you are a using Drupal 8 (actually 8.8.1), you should not using Drush 8, but rather Drush 10 installed site-locally - read docs.drush.org/en/master/install – hansfn Jan 5 at 14:16

Browse other questions tagged or ask your own question.