0

I tried updating my Google Analytics module today, but when I went to the update.php page I got this error:

Unresolved dependency. Google Analytics (Version !=7.x-2.4 required)
Google Analytics for Ubercart requires this module and version.   Currently using Google Analytics version 2.4

I've tried everything to resolve this error. I found this page pretty easy, but none of the suggestions work. I installed Google Analytics 7.x-2.6, so I shouldn't be getting this error.

So far, I've tried:

  • Clearing my cache
  • Installing Google Analytics 7.x-2.3 and 7.x-2.x-dev
  • Downloading the latest version of Ubercart
  • Refreshing update.php and clearing browser's cache
  • Modifying ubercart module's uc_googleanalytics.info like the link above describes

I can't disable the Google Analytics module either because the checkbox is greyed out

0

If you are seeing the message Unresolved dependency. Google Analytics (Version !=7.x-2.4 required) when you have Google Analytics 7.x-2.6 installed, then almost certainly you have a duplicate copy of the Google Analytics module somewhere under your web root. That is not allowed in Drupal. When Drupal scans the file system looking for modules it will find both copies, and you don't know which copy Drupal will end up using (you can even have a case where some files from one copy are used and some files from the second copy are used!). Make sure you delete the old module entirely, or if you really want to save a copy then move it somewhere NOT under the Drupal web root.

1
  • Try to search for googleanalytics.info in your root directory by find . -name googleanalytics.info – berramou Jan 4 '20 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.