1

I am running drupal 7 on Arch Linux with PHP 5.3, nginx, and php-fpm. I can't upload any image, and I get the following error:

An unrecoverable error occurred. The uploaded file likely exceeded the maximum file size

php.ini, nginx.conf, and my.conf all have their respective directives set to allow 1GB. I get this error even if I try to upload 1KB.

Is there any workaround?

  • That error message should have more after it, and report what it thinks the max filesize is (the min of post_max_size and upload_max_filesize). – mpdonadio Apr 22 '12 at 19:37
3

It was the nginx progress module. I disabled that, and everything now works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.