After I install the devel module I can no longer configure any blocks, I get an internal server error. I uninstalled and the issue stopped, re installed and its an issue again.

Furthermore, I cannot see the grey box in the lower left hand side of the browser where I can access all the variables available in a given page. This is the main reason for attempting to use the module. The module is successful in printing all SQL queries at the bottom of the page however. Any insight as to what might be wrong?

Update: I can also no longer uninstall the devel module from within the drupal backend, i receive the same error when trying to access the uninstall page, I will have to remove it manually from the file system

Update: Removed the devel module once again and problem is gone...

  • Can you provide some details about what versions of Drupal and Devl you are using, exactly which sub-modules of Devel you have enabled and especially the text of the server error you are receiving (you may need to check your server's php.error log)? – sheena_d Apr 22 '12 at 17:09
  • 1
    What do your Drupal / PHP error logs say? – acouch Apr 22 '12 at 17:10
  • The drupal version is the latest stable release, 7.12 and the same for the devel module, i literally just downloaded and installed a new version this morning. – A_funs Apr 22 '12 at 17:23
  • I have devel, devel generate, and devel node access enabled – A_funs Apr 22 '12 at 17:39
  • The error is a 500 server error not a php error – A_funs Apr 22 '12 at 17:44

Based on your comment about the 500 error and the menu entry problems, I suspect that the problem isn't really with the Devel module, but rather with your server.

Take a look at your Apache error_log to see what is causing the 500. Following the steps for fixing a WSOD may also help.

A total guess is that you are running out of memory, and this is happening during the menu rebuild phase when you have an empty cache. Enabling the Devel module likely was just the tipping point and now you are seeing memory problems. You can try increasing the memory_limit and see if that fixes things. But, you really do need to look at the error logs and find the true cause of the 500 errors.

  • according to the error logs the file does not exist, admin/structure/block/system/main-menu/configure. – A_funs Apr 22 '12 at 18:36
  • That isn't a file. It is a URL handled by the Drupal menu system. The reason for the 500 should be there, though. – mpdonadio Apr 22 '12 at 19:30
  • the reason for the error is the page supposedly does not exist – A_funs Apr 22 '12 at 19:43
  • 1
    A URL not existing results in a a 404 error. You said you were getting a 500 error, which is typically a server configuration issue. – mpdonadio Apr 22 '12 at 20:01
  • I think the 500 error was just because i did not have a 404 error page setup, I made one and now the clicking on "configure" in the blocks admin page leads me there – A_funs Apr 22 '12 at 20:04

i'm getting the same error, I installed the module and when I try to configure it on the admin/config/development/devel I get this error: "The conexion was restablished".

In admin/reports/dblog I get this message Notice: Undefined offset: 1 in mysite_process_table() (line 2139 of /var/www/html/sites/mysite.com/modules/custom/hotsite/hotsite.module).

the mysite_process_table()

function mysite_process_table() {

$arg = arg(1);

$items = explode('-', arg(1));

$ids = array();

foreach ($items as $item) {

$temp = explode('=', $item);

array_push($ids, $temp[1]); //THIS IS THE LINE 2139


foreach ($ids as $pos => $id) {


$update = db_update('save_l')

->fields(array('save_l.poss' => $pos))

->condition('id', $id)




¿some advices?


I was experiencing a similar issue and came across this question.

After enabling Devel and its option "Display $page array", I was getting a 500 error when I tried to reach /admin/modules/. I had to remove the Devel directory to get back into /admin/modules/. (If I also enabled Devel Themer, I was also getting a the "white screen of death".)

Disabling "Display $page array" resolved my issues.

EDIT: I also posted about this on drupal.org and was told the cause was a low php memory_limit setting in php.ini. The link: http://drupal.org/node/1759394

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.