0

I have a problem with a website I'm working on.
When I clear the cache on my local site, the staging breaks.
When I clear the cache there, it works again but this time the local isn't working anymore...

Any ideas what's causing this bug?

I get this as an error message in my terminal for the local site:

Uncaught PHP Exception Drupal\Component\Plugin\Exception\PluginNotFoundException: "The "path_alias" entity type does not exist." at .../web/core/lib/Drupal/Core/Entity/EntityTypeManager.php line 150

We're using version 8.8.2

The database is shared between the local and the live site.

  • have you tried drush updb ? have you recently updated to core 8.8 and higher? what drupal core version is it? please provide more info – Sohail Feb 10 at 15:59
  • Any chance you are sharing the db between the two instances? – Alfred Armstrong Feb 10 at 16:19
  • 4
    You can't share a db between different codebases. You need to take a copy of the db and use that for your local development. – Alfred Armstrong Feb 10 at 16:31
  • 1
    Sharing a db is a bad practice, you really need to have 2 db. – lchabrand Feb 10 at 16:35
  • 1
    If by sharing a database you mean more than one site (on different code/branches) is using the same database (instead of multiple databases in one sql instance), this would be bad practice. It will cause configs to keep shifting and reporting the wrong schema updates in the database, for starters, depending on which site is reading the database. – Kevin Feb 10 at 16:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.