0

We are running Drupal 7.69 under PHP 7.3.13 on Bluehost. Not sure what happened, but when I try to browse to update.php to perform database updates, I get the prompts as expected to update the database and code, and click Continue, but then it just goes back to the home page with no error message displayed.

Webform 7x-4.22 is installed and had been working. When I browse to a node that has a web form, or attempt to create a new web form, I have the standard tabs, including the text lead in), but no tabs displaying for fields for the form.

When I click on Permissions under Modules for Webform, it shows all of the field types checked, and it appears to configured as it has before.

The only errors that I see in the error log seem to be variations on

Warning: Use of undefined constant Y - assumed 'Y' (this will throw an Error in a future version of PHP) in eval() (line 19 of /home3/drenched/public_html/modules/php/php.module(80) : eval()'d code).

Any suggestions on where to look? Kind of desperate to solve this.

  • You probably mean Drupal 7.69. Is it possible to use drush (drush updb) to do the update? It usually performs better on updates. Maybe try to clear caches, (drush cc all) The eval error is a little hard to debug, since it could be triggered anywhere, best guess is to look for views, blocks or nodes with a php filter applied. If you cannot find it you can try and disable the PHP module. – Rick B Feb 27 at 14:21
  • Yes, sorry, I did mean Drupal 7.69. I haven't set up drush before, Is there a quick guide to setting up/using drush? – Michael Kenton Mahler Feb 27 at 14:41
  • I also disabled PHP filters, the only module I could find that referenced PHP on the modules afmin page. – Michael Kenton Mahler Feb 27 at 14:46
  • Has the eval error been gone after disabling the php filter module? I'am not familiair with bluehost, but they seem to be running cPanel, you have a terminal or ssh access with cPanel and by default composer is installed so you can install drush via composer docs.cpanel.net/knowledge-base/web-services/… you better specify the version number since drush 9 is default and only for drupal 8 and drush 8 is for drupal 7 only: composer require drush/drush:~8.x – Rick B Feb 27 at 20:40
  • Eval error is gone, and no new errors are making it into the log, but I still have the same issue with update.php and webform,. Haven't been able to figure out drush instllation, – Michael Kenton Mahler Feb 28 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.