0

My ISP has a 1Gb limit and blocked my site.
The file grew to 16 Gb in less than a week. I emptied the watchdog sql file in the database with phpAdmin. This overcame the block and the site restarted, with an SQL error on the front end and hundreds of SQL errors on the back end, which still, nevertheless, will start.
In less than 10 minutes after emptying the file, the size had returned to 1 Gb. 45 minutes later, there were 250,000 rows occupying 3 Gb.

The site is normally quiet. It has had little in the way of addition in the last 6 months and serves about 200-500 pages a day.

The logged error is the following.

Deprecated: assert(): Calling assert() with a string argument is deprecated in Drupal/Core/Plugin/DefaultPluginManager.php on line 151

2
  • Go to /admin/config/development/logging for Database log messages to keep lower it to 100.
    – No Sssweat
    Feb 29, 2020 at 12:48
  • 1
    New PHP version and old Drupal? Check the requirements of your Drupal version.
    – 4uk4
    Feb 29, 2020 at 14:27

1 Answer 1

3

You have a few options here.

For the short term, you can disable database logging on /admin/modules/uninstall until you can get the full situation under control.

You can disable assertions. Search yout settings file(s) and set

assert_options(ASSERT_ACTIVE, FALSE);

You should also edit your php.ini file to set zend.assertions=0.

You can then enable database logging again.

That said, it seems like you are running an old version of Drupal. PHP 7 changed the way assertions work, this was fixed in core in late 2017 and was part of Drupal 8.5. You should update your site to fix this, and get the security updates that have been made since then.

3
  • Thanks very much for the reply. Do you mean settings.php?? I'm on Drupal 8.44. I had a lot of trouble upgrading to 8.5 and decided to stick. There seem to updates almost daily these days. Feb 29, 2020 at 20:50
  • @MikeLeadbetter Check settings.php and settings.local.php, or add that line to settings.php.
    – mpdonadio
    Feb 29, 2020 at 20:51
  • I'm on Drupal 8.44 @MikeLeadbetter There has been several security updates since then. The latest version is 8.8.2. I suggest you find the solution to your upgrading issue rather than leaving the backdoor wide open. Perhaps you didn't do database updates by going to yoursite.com/update.php after you placed the new core files.
    – No Sssweat
    Mar 1, 2020 at 6:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.