0

I'm going to pull my hair out if I stare at this problem any longer. I've seen the similar questions and tried everything but I can't fix this issue with module dependency versions.

I'm using Composer require drupal/<module_name> and I've tried including specific versions too but that hasn't worked. I see that the current version number isn't being displayed at the end of the error message which makes me wonder whether the system knows what version is even installed?

I also don't understand how so many modules can be asking for different versions of the same dependency. How can you possibly resolve that :|

I should also add that I was in the process of converting manually installed modules into Composer controlled dependencies. I'm not sure if that would make a difference.

It really seems to me that Drupal doesn't know what versions of Modifiers and Paragraphs are installed but I don't see how.

The error

  • 1
    I'd always start with rm composer.lock && rm -rf vendor/ && composer install -n on a local copy of the site, followed by drush cr && drush -y updb. – leymannx Mar 28 at 16:24
  • Also check that composer (the tool) itself is up to date! – vrijdenker Mar 28 at 17:16
  • Thanks for the suggestions. I tried the above but even after using composer clear-cache it still shows "cloning XXX from cache" which is odd. The update still shows the "unresolved dependency" messages and the update looks like this: > [notice] Update started: paragraphs_library_update_8004 > [error] Cannot add field paragraphs_library_item_revision_field_data.label: field already exists. > [error] Update failed: paragraphs_library_update_8004 [error] Update aborted by: paragraphs_library_update_8004 [error] Finished performing updates. – Must Impress Mar 28 at 17:51
  • I've just edited the question above with updated details – Must Impress Mar 29 at 9:34
0

So, the system couldn't decide what version of the modules were installed. Here is a fix:

https://www.drupal.org/project/modifiers/issues/3052416

Basically, install Git Deploy module to add versioning details to modules .info files.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.