0

We had an issue on a Drupal 8.8.2 site, had to restore DB, Core and Vendor, now anyone visiting the site gets the site as normal, but if admin logs in I receive:

Drupal 8.8.2 Drupal already installed - To start over, you must empty your existing database and copy default.settings.php over settings.php. - To upgrade an existing installation, proceed to the update script. - View your existing site.

Of note: Rather then restore over existing db I created a db2, restored the DB to it and pointed the settings to it (not sure if that is the issue)

I can't figure out how to stop that page from loading. I don't want to start over, running the update script does nothing but bring me back to the same page. View your existing site does take me to site but can't edit anything (looks like it just logs me out).

4
  • I had to restore a site recently and a similar issue, not sure if exactly the same. Fix for me was that I needed to also delete the config folder with the long hash name inside sites. Apr 2, 2020 at 14:14
  • Thanks for the suggestion....Just tried that, now it goes to the Install Wizard. Apr 2, 2020 at 14:47
  • Going through Wizard gets me right back to same place. Apr 2, 2020 at 14:58
  • Check your MySQL logs for error messages (e.g. closed connections). You may have run into a problem with too low packet sizes in your MySQL server configuration. max_allowed_packet is your friend then. Apr 3, 2020 at 8:30

2 Answers 2

2

Seeing the install page on an already installed Drupal site usually is a sign of problems with your database connection before the request has been processed by PHP.

This may have a wide range of causes, most likely related to your database server configuration.

The first thing to check is your database logs, which may give a hint on how to solve your issue.

We often experienced a similar behavior on sites that heavily use the database. E.g. sending big queries when rebuilding page caches on complex pages. The solution there was to ensure a high enough max_allowed_packet setting. See here for more details on how to do that.

1
  • True, I increased the max allowed packet and it works fine, thank you very much Jul 8, 2021 at 10:23
-4

Open you XAMPP server follow the following steps MySQL>Config>my.ini It will opena notepad file serach for max_allowed_packet and then increase the size as per your needs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.