1

We have Drupal 8.8.5 running on CentOS Linux 7 with PHP 7.1.33.

Was trying to update modules using composer. Composer said they were updated, but when I went into program, they weren't. In troubleshooting, I deleted the "vendor" directory. Now, I get this error:

[root@ip-172-31-13-94 master]# composer update --with-dependencies Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1 - drupal/core-recommended 8.8.0 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.0-beta1 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.0-rc1 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.1 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.2 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.3 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.4 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.5 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.8.x-dev requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.9.0-beta1 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.9.0-beta2 requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - drupal/core-recommended 8.9.x-dev requires composer/installers v1.7.0 -> satisfiable by composer/installers[v1.7.0]. - Conclusion: don't install composer/installers v1.7.0 - Installation request for drupal/core-recommended ^8.8 -> satisfiable by drupal/core-recommended[8.8.0, 8.8.0-beta1, 8.8.0-rc1, 8.8.1, 8.8.2, 8.8.3, 8.8.4, 8.8.5, 8.8.x-dev, 8.9.0-beta1, 8.9.0-beta2, 8.9.x-dev].

Can someone tell us how to resolve this? Thanks!

  • 2
    You deleted the vendor directory, your only recourse here is composer install. Modules aren't installed to vendor either, by the way. – Kevin Apr 20 at 3:32
  • $ composer install (results in same error) Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. – SomebodySysop Apr 22 at 19:06
2

Resolved the issue:

$ composer selfupdate

Updating to version 1.10.5 (stable channel). Downloading (100%)
Use composer self-update --rollback to return to version 1.6.2

Appaprently, my version of composer was too old.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.