2

I'm running into an issue when updating to Drupal core 8.8.0. I've removed both the vendor folder and the composer.lock file, as per instructions on this link https://www.drupal.org/node/2700999#s-special-considerations-for-upgrading-to-drupal-880-and-later

I run composer require drupal/core-recommended:^8.8 --update-with-dependencies and I get the following:

  Problem 1
    - Conclusion: don't install drupal/core 8.8.5
    - Conclusion: don't install drupal/core 8.8.4
    - Conclusion: don't install drupal/core 8.8.3
    - Conclusion: don't install drupal/core 8.8.2
    - Conclusion: don't install drupal/core 8.8.1
    - Conclusion: don't install drupal/core 8.8.0
    - Conclusion: don't install drupal/core 8.8.0-rc1
    - Conclusion: don't install drupal/core 8.9.0-beta2
    - Conclusion: don't install drupal/core 8.9.0-beta1
    - Conclusion: don't install drupal/core 8.8.0-beta1
    - Installation request for acquia/lightning 4.0.4 -> satisfiable by acquia/lightning[4.0.4].
    - Conclusion: don't install drupal/core 8.8.0-alpha1
    - Conclusion: don't install drupal/core 8.9.x-dev
    - acquia/lightning 4.0.4 requires drupal/claro ^1.0 -> satisfiable by drupal/claro[1.x-dev, 1.0.0-beta1, 1.0.0-alpha5, 1.0.0-alpha4, 1.0.0-alpha3, 1.0.0-alpha2, 1.0.0-alpha1].
    - don't install drupal/core 8.8.x-dev|don't install drupal/claro 1.x-dev
    - don't install drupal/core 8.8.x-dev|don't install drupal/claro 1.0.0-beta1
    - don't install drupal/core 8.8.x-dev|don't install drupal/claro 1.0.0-alpha5
    - don't install drupal/core 8.8.x-dev|don't install drupal/claro 1.0.0-alpha4
    - don't install drupal/core 8.8.x-dev|don't install drupal/claro 1.0.0-alpha3
    - don't install drupal/core 8.8.x-dev|don't install drupal/claro 1.0.0-alpha2
    - don't install drupal/core 8.8.x-dev|don't install drupal/claro 1.0.0-alpha1
    - Installation request for drupal/core ^8.8.0 -> satisfiable by drupal/core[8.8.0, 8.8.0-alpha1, 8.8.0-beta1, 8.8.0-rc1, 8.8.1, 8.8.2, 8.8.3, 8.8.4, 8.8.5, 8.8.x-dev, 8.9.0-beta1, 8.9.0-beta2, 8.9.x-dev].

At this point, running composer prohibits drupal/core:8.8.0 won't work because I removed drupal/core as per instructions in the link above.

I can successfully update to 8.7.13, so maybe I can settle for that for now. But our team wants to be ready for Drupal 9 and upgrading to 8.8 will make that transition easier, I hear.

Should I update to 8.7.13 first, before attempting to upgrade to 8.8?

EDIT I'm able to update to Drupal 8.8 by removing the vendor folder and composer.lock and removing acquia/lightning. I reinstalled acquia/lightning after Drupal core was added. I am now running into issues when running drush dbupdate.

6
  • 1
    Because you're doing it wrong, please follow the Updating Drupal 8 documentation.
    – No Sssweat
    Apr 22, 2020 at 1:34
  • I have tried just running composer update drupal/core --with-dependencies. I don't get any errors but it stays at 8.7.9
    – kcsting
    Apr 22, 2020 at 2:08
  • And rm composer.lock && rm -rf vendor/ && composer install gives you what?
    – leymannx
    Apr 22, 2020 at 5:13
  • 2
    It looks like the issue might be with acquia lightning.
    – mradcliffe
    Apr 22, 2020 at 11:49
  • 1
    @mradcliffe I removed acquia/lightning from composer.json and ran the update again. It worked, but now I'm debugging some database errors that came out when I ran drush dbupdate.
    – kcsting
    Apr 23, 2020 at 1:24

2 Answers 2

1

In your composer.json file (found in the root of your drupal site) find the line "drupal/core": "x.xx" and change it to "drupal/core": "~8.8" and then run composer update drupal/core --with-dependencies

Also, don't forget to run your database updates after! (run drush updb or go to your-drupal-site.com/update.php)

1
  • I tried your suggestion and it suggested I remove acquia/lightning from my composer.json file. I ran the update again and it worked in composer, but now there are database problems being encountered.
    – kcsting
    Apr 23, 2020 at 1:29
1

I can see you're using acquia/lightning which is not a dependency from core but the other way around, so running that command with the dependencies flag will not work.

Run the command as follows:

$ composer update drupal/core acquia/lightning --with-dependencies

This will tell composer to update both Core and Lightning. Note, this is still constrained to having your composer.json not fixed to a specific version, so ensure they are specified with either a ^ or ~ accordingly.

Also note that you can still face individual constraints that need updating as dependencies from Lightning itself. If that happens, just include those packages to your update command.

You can also refer to https://github.com/acquia/lightning/releases for the release notes, as the maintainers usually include the required commands for you as per your version of Core accordingly.

Final note: never remove your composer.lock file and also never run composer update without any package specified, as that will update all packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.