0

Using drush on my macOS. Using Nginx and MYSQL through brew. Website is running fine. The other drush commands work fine, drush cr, drush cc, etc. But running drush migrate:status or drush ms results in

 error SQLSTATE [hy000] [2002] No such file or directory 

in terminal. same for all migrate drush commands.

Running Drupal 8.8.5 Lightning Distro.

My settings.php is set up 127.0.0.1 but still no luck.

image of console

  • 1
    You have to provide migrate with external db credentials or a .csv file, its not going to magically know from where you want to import. – No Sssweat Apr 22 at 19:50
  • As migrate status checks/compares the import source versus your site's db to see what has or has not been imported. – No Sssweat Apr 22 at 19:54
  • I created a import module with JSON plugin as a source. It's install and enabled. Also when I run drush --filter=migrate_tools it comes back with The "specified command category migrate_tools does not exist." That module is installed and enabled as well. – Tyler Apr 22 at 20:43
1

I had this problem when upgrading/downgrading php to work with drush migrate. Check if the mysql.sock is right in php.ini:

First check what php.ini file is used in terminal:

php --ini

Then open the php.ini file and change/add:

pdo_mysql.default_socket=/Applications/MAMP/tmp/mysql/mysql.sock

or the mysql.sock you are using. To find your mysql socket in terminal use:

mysql_config --socket
| improve this answer | |
  • Nice, I have a new error that says "Access denied for user 'root'@'localhost' (using password: YES)" but changing the socket fixed the last error. – Tyler May 4 at 4:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.