I am using Search API Solr (Version: 7.x-1.14), and search was working fine but has stopped working. I now see "The Solr server of Solr could not be reached" at admin/config/search/search_api. In the past, when I have gotten this message, it was because solr had stopped running. In this case, solr is running. I have confirmed this with the "bin/solr status" command.

My settings should all be fine, since they have not changed and were working fine before:

Solr Host: localhost
Solr port: 8983
Solr path: /solr/drupal

What could cause Drupal to now be unable to reach solr when no settings have changed and solr is running?

1 Answer 1


I'm not sure what caused the problem in the first place, but it was ultimately resolved by running solr with a different user. In trying to address the original problem (whatever it was), I ran solr using the wrong user. Once I ran it with my designated "solr" user, Drupal could then reach solr.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.