0

In Drupal 7, on a content type's "Manage display" tab, it was possible to trim strings to a particular length, by setting the field's format to "Trimmed".

For example, you could trim a long text field to 200 characters for the Teaser mode.

This doesn't seem to be possible in Drupal 8 – I don't have the option to set a custom-field's format to "Trimmed". (The only option available is "Plain text".)

Has the "Trimmed" format indeed been removed for custom fields? If so, is there a way to get it back?

0

Your field type needs to be Text (formatted, long). enter image description here

Then on the display settings page, you can change the display format to Trimmed, and edit the settings (by clicking the gear) to change the character limit.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.