1

I changed my server and when I uploaded my site this error appeared:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@xxxxxxxx.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2 Server at xxxxxxx.com Port 80

I tried to upload it again without success. I tried uploading the index.html file without the drupal site, and it worked.

How can I solve this problem?

  • 4
    Try temporarily removing the .htaccess file from the root of the site and see if you still get a 500 error – Clive Apr 25 '12 at 22:33
5

I had this problem too, due to a bug in my PHP code and the fact php.ini was not set to display errors.

Find the line display_errors = Off in php.ini and change it to display_errors = On. This way you'll see the specific php error message instead of the generic internal server error.

2

I had the same problem on my laptop when setting up a basic Drupal 7 site.

The problem was Apache not updating include paths etc. In my case a simple Apache restart sorted it.

0

Try setting the permission of the root folder to 755.

Chmod 755 "root_folder_name"
  • i tried it before and no hope – abd Apr 25 '12 at 22:29
  • did you check the error logs? What does it say? – aerozeppelin Apr 25 '12 at 22:32
  • How to enabling it? – abd Apr 25 '12 at 22:44
  • you can find the error logs inside the "logs" folder. The folder should be on the same level as "public_html" folder. The file is called "error_log". – aerozeppelin Apr 25 '12 at 22:52
0

Increase php memory limit. If new server is on shared hosting you might need a dedicated server.

0

I have that problem with hostgator and the following help me:

  1. Permission for the folder must be 755 and the files 644
  2. SuPHP was activated and the suphp user needs to be the owner of the folders and files
  3. need to increase the php memory limit
  4. If you change your domain remember to change your url base

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.