0

I have a view with several exposed filtears. The filters are of different types: checkboxes, taxonomy autocomplete and some jquery slider (I use Better Exposed Filters module).

The view shows all nodes of type A. Node type A has 15 field, each of which has a respective exposed filter within the view. Not all fields are mandatory which is why some nodes don't have value for all fields.

My problem is this (just an example to demonstrate):

  • Field A1 is called 'Location' (taxonomy) -- this is a mandatory field
  • Field A2 is called 'Retail purchasing power' (jquery slider with
    min/max values) -- this field is not mandatory

Now, a user selects in the exposed filter for 'Location' let's say 'Florida'. The view will show all nodes with Florida that also have a value for 'Retail purchasing power', but not the nodes without a value for this field.

I can see that this is the expected behaviour but in my view I have a lot of filters and there are many nodes that don't have values for some fields. Some users only search for the 'location' and don't care too much about the other filters.Tthey don't see all location because they are filterd out.

Does somebody know a way to only send the filter values that have actively been selected by the user? The min/max values form the jquery sliders should only be considered when they are used.

  • I don't see why the second exposed filter would be applied at all, unless you set some default value that is activated from the start on the page load. Add info to your question about how you're setting up the second exposed filter. – prkos Jun 4 at 21:04
0

I can confirm that on page load the option jQuery UI slider of the Better Exposed Filters module does apply the minimum value set in options.

The minimum value is displayed in the slider, so it's a visible cue that it will be displayed.

If you delete the number in the slider and then apply other filters, the slider filter will not be applied!

But the minimum value will still be visible in the slider on page reload (if you're not using Ajax in Views).

I couldn't find any similar issues so I created a new one: jQuery UI slider Exposed filter always applied

Add your test results/observations there.

| improve this answer | |
  • Thanks for confirming. In my case I am using the ‘ok between’ operator for my sliders. I will add my findings in the issue you’ve created. Thanks. – ThuleNB Jun 5 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.