1

I'm currently using the drupal/core-recommended project and I'm having issues updating to 8.9.0.

Some reason composer is updating it to 8.9.0-beta2.

Steps I took to update was go into my composer.json file and changed: "drupal/core-composer-scaffold": "^8.8", "drupal/core-recommended": "^8.8",

TO "drupal/core-composer-scaffold": "^8.9", "drupal/core-recommended": "^8.9",

Then ran composer install

Then it just downloads the beta version instead of the stable version.

Anyone know why?

6
  • Have you tried these commands for updating Drupal? Just Core: $>composer update drupal/core --with-dependencies or for Core and Contrib Modules: $>composer update --with-dependencies Personally I don't edit the composer files and then run install. I just run these commands and so far has always worked well. Jun 4, 2020 at 23:19
  • I did and I also did: composer update drupal/recommended --with-dependencies Jun 5, 2020 at 0:46
  • 1
    I ran into this issue yesterday. Running composer require drupal/core-recommended:8.9 --update-with-all-dependencies told me I had a conflict with symfony/polyfill-php72. I removed the section on this library from composer.lock, and was able to properly update to 8.9. Maybe this can help. Back up your system appropriately before running any of these commands.
    – Jaypan
    Jun 5, 2020 at 1:25
  • Hi Jaypan! Big fan of you by the way haha. In my composer.lock I have a lot of symfony/polyfill-php72. Can you tell me which line to remove? Thank you! Jun 5, 2020 at 2:06
  • 1
    I figured it out!! I tried composer require drupal/core-recommended:8.9 --update-with-all-dependencies and got a conflict with my guzzle. I updated guzzle and it's working now!! Thank you Jaypan!! Jun 5, 2020 at 2:30

0

Browse other questions tagged or ask your own question.