0

I inherited an out of date Drupal 8 site, and have been tasked with extracting some data for import into another location. I thought I would create a View to query the data that I'm after, and then work to export it.

When I navigate to http://localhost/admin/structure/views, I get the following error:

The website encountered an unexpected error. Please try again later.</br></br><em class="placeholder">Drupal\Core\Entity\EntityMalformedException</em>: The &quot;view&quot; entity cannot have a URI as it does not have an ID in <em class="placeholder">Drupal\Core\Entity\EntityBase-&gt;toUrl()</em> (line <em class="placeholder">191</em> of <em class="placeholder">core\lib\Drupal\Core\Entity\EntityBase.php</em>).

Other pages that I have tested on the site load correctly.

I have migrated the site by copying the entire directory structure and the database to my local machine, updated settings.php to reflect the local database. I cleared caches and am able to log in and navigate to a large sample of pages successfully.

Some searching on this particular error doesn't seem to get me too far, except to some references of other modules (not Views).

Help?

2
  • Can you load the Extend page (modules list)? Anything on Status Report? Can you save the modules list form? Tried updating Drupal? May be relevant: drupal.org/forum/support/post-installation/2018-01-06/…
    – prkos
    Jun 17, 2020 at 23:17
  • If the database in locally works then it should work on server too, Try to import the local database to server and see. I think this issue seems like some modules are removed without uninstalling it. So it might be not reflected in the database.
    – KTM
    Jun 18, 2020 at 7:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.