I've created a CSV feed via Views Export that exports out data for a content type. I'm then using Feeds to import that onto another Drupal site.

Everything except the images are working, when I run import it's stating

Failed importing 2 RSS Item items.

The content failed to validate with the following errors: Image (field_image): Image: this field cannot hold more than 1 values. Please check your mappings.

The field in question on Site A has a single limited value of 1, and checking the CSV export it's only showing one value, the absolute url of the image on Site A.

I've attempted to use Feeds Tamper and use all the plugins I can think of to fix this, but due to my freshness to Feeds and Feeds Tamper I'm not sure if this is a bug or misconfig on my part. Everything else is importing as expected onto Site B.

How can I get the import running successfully?

  • 1
    Did you check the feeds mapping and made sure you didn't accidentally add this field twice?
    – No Sssweat
    Jun 26 '20 at 18:29
  • Is the field on site B also single value? Do you have quotes around the cell values in your CSV? Maybe you have extra spaces around the link and it's getting joined with the next string as multivalue? Why do you need Tamper if you're not using multivalue fields? Maybe you set up the mapping as multivalue by accident?
    – prkos
    Jun 26 '20 at 23:08
  • @NoSssweat where the image field has three fields to map: image ID, image alt, and image title, should I be mapping three separate field exports from Site A to each of these three fields, or can I map the same 'Image' export field to them?
    – Rob Hern
    Jun 29 '20 at 7:48
  • @prkos Site B is single value, there are double quotes around each value in the CSV export, there doesn't appear to be spaces around the value when I open it in an edotir. I was using tamper to try to filter out the second value. How would I know if i set it up as a multivalue?
    – Rob Hern
    Jun 29 '20 at 7:49
  • Filter out the second value? What second value? You're claiming they're all single values in quotes. Update your questions with all info about the Field settings you're migrating (multivalue or not) and a sample of your CSV info for the import.
    – prkos
    Jun 29 '20 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.