0

Under /admin/modules/update, Drupal core is listed as requiring update from 8.8.8 to 8.9.1. I have started my Drupal installation using the drupal/recommended-project project template and I used composer update drupal/core-recommended --with-dependencies to update Drupal core, but when I run the above command, all I get is this message.

Nothing to install or update

Am I missing something?

This is the content of the composer.json file.

{
    "name": "drupal/recommended-project",
    "description": "Project template for Drupal 8 projects with a relocated document root",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "homepage": "https://www.drupal.org/project/drupal",
    "support": {
        "docs": "https://www.drupal.org/docs/user_guide/en/index.html",
        "chat": "https://www.drupal.org/node/314178"
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ],
    "require": {
        "composer/installers": "^1.2",
        "drupal/addtoany": "^1.14",
        "drupal/admin_toolbar": "^2.3",
        "drupal/better_exposed_filters": "^4.0",
        "drupal/blazy": "^2.1",
        "drupal/business_rules": "^1.0",
        "drupal/captcha": "^1.1",
        "drupal/change_pwd_page": "^1.0",
        "drupal/colorbox": "^1.4",
        "drupal/conditional_fields": "^1.0",
        "drupal/core-composer-scaffold": "^8.8",
        "drupal/core-project-message": "^8.8",
        "drupal/core-recommended": "^8.8",
        "drupal/dynamic_entity_reference": "^1.10",
        "drupal/entity_reference_revisions": "^1.8",
        "drupal/eva": "^2.1",
        "drupal/field_group": "^3.1",
        "drupal/field_permissions": "^1.0",
        "drupal/field_timer": "1.x-dev",
        "drupal/firebase": "^2.0",
        "drupal/flag": "^4.0",
        "drupal/fontawesome": "^2.16",
        "drupal/google_analytics": "^3.1",
        "drupal/jquery_ui_accordion": "^1.1",
        "drupal/jquery_ui_checkboxradio": "^1.2",
        "drupal/module_filter": "^3.1",
        "drupal/pathauto": "^1.6",
        "drupal/persistent_login": "^1.3",
        "drupal/reroute_email": "^1.2",
        "drupal/simple_fb_connect": "^3.1",
        "drupal/simplify": "^1.1",
        "drupal/sitewide_alert": "^1.3",
        "drupal/slick": "^2.2",
        "drupal/slick_views": "^2.3",
        "drupal/sms": "^1.3",
        "drupal/sms_simplegateway": "^1.1",
        "drupal/subpathauto": "^1.1",
        "drupal/telephone_validation": "^2.3",
        "drupal/token": "^1.6",
        "drupal/token_filter": "^1.1",
        "drupal/ultimate_cron": "^2.0",
        "drupal/video": "^1.4",
        "drupal/views_infinite_scroll": "^1.7",
        "drupal/webform": "^6.0",
        "drush/drush": "^10.2",
        "wikimedia/composer-merge-plugin": "^1.4"
    },
    "require-dev": {
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "extra": {
        "merge-plugin": {
            "include": [
                "web/modules/contrib/webform/composer.libraries.json"
            ]
        },        
        "drupal-scaffold": {
            "locations": {
                "web-root": "web/"
            }
        },
        "installer-paths": {
            "web/core": ["type:drupal-core"],
            "web/libraries/{$name}": ["type:drupal-library"],
            "web/modules/contrib/{$name}": ["type:drupal-module"],
            "web/profiles/contrib/{$name}": ["type:drupal-profile"],
            "web/themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/Commands/contrib/{$name}": ["type:drupal-drush"],
            "web/modules/custom/{$name}": ["type:drupal-custom-module"],
            "web/themes/custom/{$name}": ["type:drupal-custom-theme"]
        },
        "drupal-core-project-message": {
            "include-keys": ["homepage", "support"],
            "post-create-project-cmd-message": [
                "<bg=blue;fg=white>                                                         </>",
                "<bg=blue;fg=white>  Congratulations, you’ve installed the Drupal codebase  </>",
                "<bg=blue;fg=white>  from the drupal/recommended-project template!          </>",
                "<bg=blue;fg=white>                                                         </>",
                "",
                "<bg=yellow;fg=black>Next steps</>:",

                "  * Install the site: https://www.drupal.org/docs/8/install",
                "  * Read the user guide: https://www.drupal.org/docs/user_guide/en/index.html",
                "  * Get support: https://www.drupal.org/support",
                "  * Get involved with the Drupal community:",
                "      https://www.drupal.org/getting-involved",
                "  * Remove the plugin that prints this message:",
                "      composer remove drupal/core-project-message"
            ]
        }
    }
}
0

I think you have to change the following lines of your composer.json

    "drupal/core-composer-scaffold": "^8.8",
    "drupal/core-project-message": "^8.8",
    "drupal/core-recommended": "^8.8",

with

    "drupal/core-composer-scaffold": "^8.9",
    "drupal/core-project-message": "^8.9",
    "drupal/core-recommended": "^8.9",

As the current settings constraints the drupal/core to 8.8.x version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.