0

I downloaded the real_aes-8.x-2.2.zip file from the Real AES project page, unzipped and copied it to contrib module folder (/var/www/html/modules/contrib).

While trying to enable this module using drush en real_aes, I get below error:

Module real_aes doesn't meet the requirements to be enabled. [error] Please install the Defuse PHP-encryption library via Composer. See README.txt (Currently using Defuse PHP-Encryption[error] library version Not Installed)

So now I ran the command composer require defuse/php-encryption to install Defuse PHP-encryption. I could see that it is downloaded to the location /var/www/html/vendor.

After this, even though the Defuse PHP-encryption is downloaded, if I try to enable the Real AES module using Drush command and also tried Drupal module interface, it still throws the above error.

  • Drupal version: 8.6.5
  • PHP Version : 7.0.32
  • Drush version: 8.1.18

Any help appreciated resolving this issue.

2
  • So your site is managed with Composer? Then you composer require drupal/real_aes and it will also get you the library. Otherwise ensure you download the correct version of the library composer require defuse/php-encryption:^2.2. Flush cache and retry. Next thing: your Drush version is incompatible with Drupal 8, fix that. Next thing: Your Drupal version is out of date, fix that, too. – leymannx Jul 10 '20 at 8:37
  • You need to execute composer require defuse/php-encryption in the correct directory, in order to let Drupal find the library. Then, since you used Composer to add the library, you could as well add the module with composer require drupal/real_aes as @leymannx said. – kiamlaluno Jul 10 '20 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.