1

I want to update my Drupal website from 8.8.8 to 8.9.2.

I have separately tried each of the below:

  1. Run composer update
  2. Removing both Vendor directory and composer.lock file then run composer install
  3. Removing both Vendor directory and composer.lock file then run composer update
  4. Manually changing all lines in composer.json file ("drupal/core-composer-scaffold" and "drupal/core-project-message" and "drupal/core-recommended") from ^8.8 to ^8.9 then run composer install

None of the above worked for me and the site still until now running on "Drupal 8.8.8"

I have my own backup in case something wrong happened :)

For example when I removing both Vendor directory and composer.lock file then ran composer update command, I received the below:

[email protected] [~/public_html/dev.example.com]# composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 28 updates, 0 removals
  - Updating drupal/core-composer-scaffold (8.8.5 => 8.9.2): Downloading (100%)
  - Updating drupal/core-project-message (8.8.5 => 8.9.2): Downloading (100%)
  - Updating composer/installers (v1.7.0 => v1.9.0): Loading from cache
  - Installing symfony/polyfill-php80 (v1.18.0): Loading from cache
  - Updating symfony/polyfill-php72 (v1.16.0 => v1.18.0): Loading from cache
  - Updating symfony/var-dumper (v4.4.8 => v4.4.11): Loading from cache
  - Updating webmozart/assert (1.8.0 => 1.9.1): Loading from cache
  - Updating drupal/better_exposed_filters (4.0.0-beta1 => 4.0.0-beta2): Downloading (100%)
  - Updating drupal/conditional_fields (1.0.0-alpha8 => 1.0.0-alpha9): Downloading (100%)
  - Updating drupal/flag (4.0.0-beta1 => 4.0.0-beta2): Downloading (100%)
  - Updating drupal/fontawesome (2.16.0 => 2.17.0): Loading from cache
  - Updating drupal/simplify (1.1.0 => 1.2.0): Loading from cache
  - Updating drupal/sms_simplegateway (1.1.0 => 1.2.0): Loading from cache
  - Updating drupal/webform (6.0.0-alpha8 => 6.0.0-alpha12):  Checking out 6.0.0-alpha12
  - Updating symfony/finder (v4.4.8 => v4.4.11): Downloading (100%)
  - Updating nikic/php-parser (v4.4.0 => v4.7.0): Loading from cache
  - Updating consolidation/site-alias (3.0.0 => 3.0.1): Loading from cache
  - Updating symfony/filesystem (v4.4.8 => v4.4.11): Downloading (100%)
  - Updating chi-teck/drupal-code-generator (1.32.0 => 1.32.1): Loading from cache
  - Updating drush/drush (10.2.2 => 10.3.1): Downloading (100%)
  - Updating algolia/places (1.17.1 => 1.18.2): Loading from cache
  - Updating codemirror/codemirror (5.51.0 => 5.53.2): Loading from cache
  - Updating jquery/image-picker (0.3.0 => 0.3.1): Loading from cache
  - Updating jquery/select2 (4.0.12 => 4.0.13): Loading from cache
  - Updating jquery/textcounter (0.8.0 => 0.9.0): Loading from cache
  - Updating jquery/timepicker (1.13.0 => 1.13.10): Loading from cache
  - Updating progress-tracker/progress-tracker (1.4.0 => 2.0.6): Loading from cache
  - Updating giggsey/locale (1.8 => 1.9): Loading from cache
  - Updating giggsey/libphonenumber-for-php (8.12.3 => 8.12.4): Loading from cache
Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
Package zendframework/zend-diactoros is abandoned, you should avoid using it. Use laminas/laminas-diactoros instead.
Package zendframework/zend-escaper is abandoned, you should avoid using it. Use laminas/laminas-escaper instead.
Package zendframework/zend-feed is abandoned, you should avoid using it. Use laminas/laminas-feed instead.
Package zendframework/zend-stdlib is abandoned, you should avoid using it. Use laminas/laminas-stdlib instead.
Writing lock file
Generating autoload files
Scaffolding files for drupal/core:
  - Copy [project-root]/.editorconfig from assets/scaffold/files/editorconfig
  - Copy [project-root]/.gitattributes from assets/scaffold/files/gitattributes
  - Copy [web-root]/.csslintrc from assets/scaffold/files/csslintrc
  - Copy [web-root]/.eslintignore from assets/scaffold/files/eslintignore
  - Copy [web-root]/.eslintrc.json from assets/scaffold/files/eslintrc.json
  - Copy [web-root]/.ht.router.php from assets/scaffold/files/ht.router.php
  - Copy [web-root]/.htaccess from assets/scaffold/files/htaccess
  - Copy [web-root]/example.gitignore from assets/scaffold/files/example.gitignore
  - Copy [web-root]/index.php from assets/scaffold/files/index.php
  - Copy [web-root]/INSTALL.txt from assets/scaffold/files/drupal.INSTALL.txt
  - Copy [web-root]/README.txt from assets/scaffold/files/drupal.README.txt
  - Copy [web-root]/robots.txt from assets/scaffold/files/robots.txt
  - Copy [web-root]/update.php from assets/scaffold/files/update.php
  - Copy [web-root]/web.config from assets/scaffold/files/web.config
  - Copy [web-root]/sites/README.txt from assets/scaffold/files/sites.README.txt
  - Copy [web-root]/sites/development.services.yml from assets/scaffold/files/development.services.yml
  - Copy [web-root]/sites/example.settings.local.php from assets/scaffold/files/example.settings.local.php
  - Copy [web-root]/sites/example.sites.php from assets/scaffold/files/example.sites.php
  - Copy [web-root]/sites/default/default.services.yml from assets/scaffold/files/default.services.yml
  - Copy [web-root]/sites/default/default.settings.php from assets/scaffold/files/default.settings.php
  - Copy [web-root]/modules/README.txt from assets/scaffold/files/modules.README.txt
  - Copy [web-root]/profiles/README.txt from assets/scaffold/files/profiles.README.txt
  - Copy [web-root]/themes/README.txt from assets/scaffold/files/themes.README.txt

Yet the site is running on 8.8.8 Core and the /admin/reports/updates/update section of my site still asking me to update core from 8.8.8 to 8.9.2

As shown above, there is no errors at all and the update seems to be running smoothly.

Any idea what I am missing here ?

UPDATE #1:

I have tried composer update --with-dependencies and got the below output:

  - Updating drupal/core-composer-scaffold (8.8.5 => 8.9.2): Loading from cache
  - Updating drupal/core-project-message (8.8.5 => 8.9.2): Loading from cache
  - Updating composer/installers (v1.7.0 => v1.9.0): Loading from cache
  - Installing symfony/polyfill-php80 (v1.18.0): Loading from cache
  - Updating symfony/polyfill-php72 (v1.16.0 => v1.18.0): Loading from cache
  - Updating symfony/var-dumper (v4.4.8 => v4.4.11): Loading from cache
  - Updating webmozart/assert (1.8.0 => 1.9.1): Loading from cache
  - Updating drupal/better_exposed_filters (4.0.0-beta1 => 4.0.0-beta2): Loading from cache
  - Updating drupal/conditional_fields (1.0.0-alpha8 => 1.0.0-alpha9): Loading from cache
  - Updating drupal/flag (4.0.0-beta1 => 4.0.0-beta2): Loading from cache
  - Updating drupal/fontawesome (2.16.0 => 2.17.0): Loading from cache
  - Updating drupal/simplify (1.1.0 => 1.2.0): Loading from cache
  - Updating drupal/sms_simplegateway (1.1.0 => 1.2.0): Loading from cache
  - Updating drupal/webform (6.0.0-alpha8 => 6.0.0-alpha12):  Checking out 6.0.0-alpha12
  - Updating symfony/finder (v4.4.8 => v4.4.11): Loading from cache
  - Updating nikic/php-parser (v4.4.0 => v4.7.0): Loading from cache
  - Updating consolidation/site-alias (3.0.0 => 3.0.1): Loading from cache
  - Updating symfony/filesystem (v4.4.8 => v4.4.11): Loading from cache
  - Updating chi-teck/drupal-code-generator (1.32.0 => 1.32.1): Loading from cache
  - Updating drush/drush (10.2.2 => 10.3.1): Loading from cache
  - Updating algolia/places (1.17.1 => 1.18.2): Loading from cache
  - Updating codemirror/codemirror (5.51.0 => 5.53.2): Loading from cache
  - Updating jquery/image-picker (0.3.0 => 0.3.1): Loading from cache
  - Updating jquery/select2 (4.0.12 => 4.0.13): Loading from cache
  - Updating jquery/textcounter (0.8.0 => 0.9.0): Loading from cache
  - Updating jquery/timepicker (1.13.0 => 1.13.10): Loading from cache
  - Updating progress-tracker/progress-tracker (1.4.0 => 2.0.6): Loading from cache
  - Updating giggsey/locale (1.8 => 1.9): Loading from cache
  - Updating giggsey/libphonenumber-for-php (8.12.3 => 8.12.4): Loading from cache

then I ran drush updb and drush cr and yet the site still running on Core 8.8.8 !?!?!

Also, I have tried to run composer prohibits drupal/core to see what is preventing the site update and I got the below results:

[email protected] [~/public_html/dev.example.com]# composer prohibits drupal/core
drupal/addtoany                    1.14.0        requires  drupal/core (^8 || ^9)
drupal/admin_toolbar               2.3.0         requires  drupal/core (^8.8.0 || ^9.0)
drupal/better_exposed_filters      4.0.0-beta1   requires  drupal/core (^8 || ^9)
drupal/blazy                       2.1.0         requires  drupal/core (^8.8 || ^9)
drupal/business_rules              1.0.0-beta10  requires  drupal/core (~8.0)
drupal/captcha                     1.1.0         requires  drupal/core (^8.8 || ^9)
drupal/change_pwd_page             1.0.0         requires  drupal/core (^8 || ^9)
drupal/colorbox                    1.6.0         requires  drupal/core (^8.8 || ^9)
drupal/conditional_fields          1.0.0-alpha8  requires  drupal/core (*)
drupal/core-recommended            8.8.8         requires  drupal/core (8.8.8)
drupal/ctools                      3.4.0         requires  drupal/core (^8.7.7 || ^9)
drupal/dbug                        1.0.0         requires  drupal/core (~8.0)
drupal/dynamic_entity_reference    1.10.0        requires  drupal/core (^8.7.7 || ^9)
drupal/entity_reference_revisions  1.8.0         requires  drupal/core (^8.7.7 || ^9)
drupal/eva                         2.1.0         requires  drupal/core (^8 || ^9)
drupal/field_group                 3.1.0         requires  drupal/core (^8.8 || ^9)
drupal/field_permissions           1.0.0         requires  drupal/core (^8 || ^9)
drupal/field_timer                 1.x-dev       requires  drupal/core (^8 || ^9)
drupal/firebase                    2.0.0         requires  drupal/core (^8.3.0)
drupal/flag                        4.0.0-beta1   requires  drupal/core (~8.0)
drupal/fontawesome                 2.16.0        requires  drupal/core (^8 || ^9)
drupal/google_analytics            3.1.0         requires  drupal/core (^8.8.6|^9.0)
drupal/jquery_ui                   1.4.0         requires  drupal/core (^8 || ^9)
drupal/jquery_ui_accordion         1.1.0         requires  drupal/core (^8 || ^9)
drupal/jquery_ui_checkboxradio     1.2.0         requires  drupal/core (^8 || ^9)
drupal/jquery_ui_datepicker        1.0.0         requires  drupal/core (^8 || ^9)
drupal/jquery_ui_tabs              1.1.0         requires  drupal/core (^8 || ^9)
drupal/jquery_ui_tooltip           1.1.0         requires  drupal/core (^8 || ^9)
drupal/module_filter               3.1.0         requires  drupal/core (~8.0)
drupal/pathauto                    1.8.0         requires  drupal/core (^8.8 || ^9)
drupal/persistent_login            1.3.0         requires  drupal/core (^8.3 || ^9.0)
drupal/reroute_email               1.2.0         requires  drupal/core (^8 || ^9)
drupal/simple_fb_connect           3.1.0         requires  drupal/core (~8.0)
drupal/simplify                    1.1.0         requires  drupal/core (~8.0)
drupal/sitewide_alert              1.3.0         requires  drupal/core (^8 || ^9)
drupal/slick                       2.2.0         requires  drupal/core (^8.8 || ^9)
drupal/slick_views                 2.3.0         requires  drupal/core (^8 || ^9)
drupal/sms                         1.3.0         requires  drupal/core (>=8.6 <8.9)
drupal/sms_simplegateway           1.1.0         requires  drupal/core (~8.0)
drupal/smsframework                1.3.0         requires  drupal/core (~8.0)
drupal/subpathauto                 1.1.0         requires  drupal/core (^8.8 || ^9)
drupal/telephone_validation        2.3.0         requires  drupal/core (^8 || ^9)
drupal/token                       1.7.0         requires  drupal/core (^8.7.7 || ^9)
drupal/token_filter                1.2.0         requires  drupal/core (^8 || ^9)
drupal/ultimate_cron               2.0.0-alpha4  requires  drupal/core (~8.0)
drupal/video                       1.4.0         requires  drupal/core (*)
drupal/views_infinite_scroll       1.7.0         requires  drupal/core (^8.8 || ^9)
drupal/webform                     6.0.0-alpha8  requires  drupal/core (^8.8 || ^9)

Thank you,

7
  • What's the error that you're getting? Try running composer with verbose (add -v to the command) and then add the error message to your question. Commented Jul 30, 2020 at 13:52
  • @PatrickKenny there is no errors at all, please check the update of the question. Commented Jul 30, 2020 at 14:07
  • Seems like your database is out of date, as the composer output is clear enough that it's installed 8.9.2. Try running database updates and clearing cache
    – Clive
    Commented Jul 30, 2020 at 14:11
  • @Clive I did drush updb and drush cr many times and yet same problem, even in /admin/reports/status the core listed is 8.8.8 Commented Jul 30, 2020 at 14:16
  • Look at the files on disk to verify, each core module should have a version in its info file. Also make sure the right code is connected to the right database etc
    – Clive
    Commented Jul 30, 2020 at 14:19

2 Answers 2

1

Looking at your prohibits output, drupal/sms is blocking the update:

requires drupal/core (>=8.6 <8.9)

You can try switching to smsframework.

0

You should run:

composer update --with-dependencies

If that doesn't work, run:

composer prohibits drupal/core

That should tell you what is holding back the update of drupal/core.

2
  • I ran composer prohibits drupal/core and updated my question with the output, can you please check it out to see if there is something important ? Commented Aug 1, 2020 at 7:46
  • 2
    @VanessaAbiRashed, this looks like the key line: drupal/core-recommended 8.8.8 requires drupal/core (8.8.8). It's pinned at 8.8.8 specifically. Try running composer update drupal/core drupal/core-recommended --with-dependencies Commented Aug 2, 2020 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.