0

I think I might be losing myself here. I am getting an invalid YAML error on a very simple migration file that really should be working fine. Would someone mind taking a look and letting me know if they can see something obvious that I am missing? Error code is:

A colon cannot be used in an unquoted mapping value at line 14 (near "  method: row").

YAML file is:

id: data
label: 'Data'
source:
  plugin: data
  key: migrate
process:
  name: data
    -
      plugin: existing_term
      vocabulary: data_source
      source: data
    -
      plugin: skip_on_empty
      method: row
destination:
  plugin: 'entity:taxonomy_term'
  default_bundle: data_source

Migration runs without error if I remove process plugins underneath name. Same error occurs if I get rid of the second process plugin (so with no piping). Basically, if I add anything that is indented more than 1 level, this error throws. I am sure that indention is '2 spaces', and this structure has worked in the past. This is on a vanilla drupal 9 install done with composer.

1 Answer 1

2

I don't know about the details of the YAML content, but just looking at the YAML it seems to me that name: data should be just name: otherwise it is not valid YAML.

2
  • it actually should be replaced with type:
    – No Sssweat
    Aug 31, 2020 at 6:41
  • OMG. yeah. I forgot to delete that when I added in the process plugins.
    – bletch
    Aug 31, 2020 at 8:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.