1

I can't set a boolean config value to FALSE with drush. I'm using Drush 8.9.4.

pk@DC:~/$ lando drush config-set advagg.settings enabled 0 -y

 // Do you want to update enabled key in advagg.settings config?: yes.                                                  

pk@DC:~/$ lando drush config-get advagg.settings enabled
'advagg.settings:enabled': false

pk@DC:~/$ lando drush config-set advagg.settings enabled true -y

 // Do you want to update enabled key in advagg.settings config?: yes.                                                  

pk@DC:~/$ lando drush config-get advagg.settings enabled
'advagg.settings:enabled': true

pk@DC:~/$ lando drush config-set advagg.settings enabled false -y

 // Do you want to update enabled key in advagg.settings config?: yes.                                                  

pk@DC:~/$ lando drush config-get advagg.settings enabled
'advagg.settings:enabled': true

Why does setting it to false make it true?

1

When setting a boolean with drush, you need to use 0, not false.

pk@DC:~/$ lando drush config-get advagg.settings enabled
'advagg.settings:enabled': true

pk@DC:~/$ lando drush config-set advagg.settings enabled 0 -y

 // Do you want to update enabled key in advagg.settings config?: yes.                                                  

pk@DC:~/$ lando drush config-get advagg.settings enabled
'advagg.settings:enabled': false
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.