0

Using Drupal 8 W3CSS Theme 8.x-1.17, I created a subtheme. The subtheme works fine, but on the settings page, the entire #edit-favicon div is hidden; style="display: none" has been added. I can't figure out why this is happening. However, on the parent theme, the favicon is being displayed. In subtheme.info.yml, features and favicon are set to true.

settings:
  features:
    favicon: true
0

Try setting:

settings:
    features:
        favicon: true
    favicon:
        use_default: false
| improve this answer | |
  • Thanks Armando; I tried this but still don't see favicon on my settings page. I tried pasting in my info file in a comment here but the markdown formatting isn't working for me; I tried single and triple backticks. Anyway, I added your suggestion in column one below the features block, is that what you meant? I also flushed all caches, but the settings page is unchanged. – pglatz Sep 17 at 2:48
  • I've updated the answer, I think this should do – cssBlaster21895 Sep 17 at 8:00
  • Those are the settings I've ben using, still hidden. But aha! I found the answer here: drupal.stackexchange.com/questions/12834/… Turns out to recognize these changes, flushing caches isn't enough; you must uninstall and reinstall the theme. I don't like that, but it worked. Thanks so much for your suggestions. – pglatz Sep 17 at 17:15
  • ++ the answer please :) – cssBlaster21895 Sep 18 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.