1

In my Drupal 8.9.6 (Installed with Lightning distribution) Status Admin Page, there are three warnings showing after updating several modules and core to the latest versions:

  1. DEPRECATED DEPENDENCY: ENTITY EMBED Lightning Media 5.0 will not include the Entity Embed module. Please add it to your project directly: composer require drupal/entity_embed:^1.0
  2. DEPRECATED DEPENDENCY: VIDEO EMBED MEDIA Lightning Media 5.0 will not include the Video Embed Media module. Please add it to your project directly: composer require drupal/video_embed_field:^2.0.
  3. DEPRECATED DEPENDENCY: VIEWS INFINITE SCROLL Lightning Media 5.0 will not include the Views Infinite Scroll module. Please add it to your project directly: composer require drupal/views_infinite_scroll:^1.6.

I have installed the latest versions of these contributed modules through composer. But the warning not going away from the admin status page. How to remove these warning?

2
  • did you try clearing cache and run cron.
    – ARUN
    Sep 18, 2020 at 12:18
  • Yeap, several times. Sep 18, 2020 at 12:21

1 Answer 1

1

The Lighting Media modules have hard-wired checks to report this information if it finds Video Embed Media or Entity Embed & Views Infinite Scroll installed. It doesn't check the Composer requirements to see if the warning message is still applicable.

Either ignore the warning until the 5.x release is out or patch away checks in hook_requirements() if it bothers you that much.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.