0
root@0a581055a6ad:/opt/drupal# drush genc 10 --types=article


  The "--types" option does not exist.


devel-generate:content [--kill] [--bundles [BUNDLES]] [--authors [AUTHORS]] [--feedback [FEEDBACK]] [--languages [LANGUAGES]] [--translations [TRANSLATIONS]] [--add-type-label] [--skip-fields [SKIP-FIELDS]] [-h|--help] [-q|--quiet] [-v|vv|vvv|--verbose] [-V|--version] [--ansi] [--no-ansi] [-n|--no-interaction] [-d|--debug] [-y|--yes] [--no] [--remote-host REMOTE-HOST] [--remote-user REMOTE-USER] [-r|--root ROOT] [-l|--uri URI] [--simulate] [--pipe] [-D|--define DEFINE] [--notify [NOTIFY]] [--xh-link XH-LINK] [--druplicon] [--] <command> [<num> [<max_comments>]]

root@0a581055a6ad:/opt/drupal# drush --version
Drush Commandline Tool 10.3.4

According to the documentation this was an option with drush 8.x, but I don't see any equivalent in drush 9.x and up. What is the intended way to invoke genc for a particular node type with this new version of drush?

3
  • Going off the the error output, it would probably be —bundles=article – Clive Oct 11 '20 at 7:13
  • Can’t get the above to format properly, but bundles instead of types, essentially – Clive Oct 11 '20 at 7:14
  • doh! Thanks @clive :) – quant Oct 11 '20 at 11:10
1

Yeah, it's --bundles now. That's also what the error output is telling you already when echoing all possible options.

drush genc 10 --bundles article,page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.