1

Within the e-mail handlers I've selected the body as 'twig template'. But no HTML is sent.

I've activated Swiftmailer to send attachments ... is that the problem?

<p>Submitted values:</p>    
{{ webform_token('[webform_submission:values]', webform_submission, [], options) }}
<p> URL: {{ webform_token('[current-page:url]', webform_submission, [], options) }}</p>
<p> Page name: {{ webform_token('[current-page:title]', webform_submission, [], options) }}</p>

Value in body (email):

Submitted values: *Name* sfd dsf *E-mail* [email protected] [1] *Phone* sdfsdfsdf [2] *VAT* sdfsdfdfs *Question?* Yes *Newsletter* List1, List2, List3 *Message* sdfsdf sdf sdf s dfsdfs URL: https://test.test.com/page/title/subtitle Page name: Pagename [1] [email protected] [2] tel:sdfsdfsdf

4
  • Yes, HTML is selected but the only available HTML formatting is 'plain text'. ==> 'The list of available formats is restricted to those that escape HTML.' If you create a new format, there is no option to select to escape HTML....
    – Lance
    Commented Oct 23, 2020 at 9:44
  • nvm, that wasn't it.
    – No Sssweat
    Commented Oct 24, 2020 at 5:02
  • So, there is nobody that can help with this issue?
    – Lance
    Commented Nov 2, 2020 at 13:08
  • 1
    Instead, try using what I use, Mime Mail.
    – No Sssweat
    Commented Nov 3, 2020 at 0:12

1 Answer 1

4

I had similar issue with emails sent from webform module (Drupal 9.0.7 & webform 6.0.0-alpha20), solved using following steps.

  1. Install and enable Mail mail module https://www.drupal.org/project/mimemail
  2. Ensure email format is "Full html" at /admin/config/system/mimemail
  3. Go to /admin/config/system/mailsystem and choose "Mime Mail mailer" for "Formatter" and "Sender" fields under default mail settings.
  4. In your webform, go to settings-> Email/handlers -> Advanced tab. Make sure "Send email as HTML" is checked.
1
  • Let me check this. Thanks.
    – Lance
    Commented Nov 20, 2020 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.