I have a multilingual site and the content list view can be accessed like this:


There are only two administration page languages: English and Japanese, and the toolbar is displayed only in these 2 languages regardless the language_code.

However, the content list menus are displayed in according to the language_code. For example, in case of French (fr) it looks like this:

Content view

What I want to do is to display content list menus only in the administration page language. So I want that the language_code in the path to be ignored and I have the menus shown only in English or Japanese.

Could you please advise some approaches to solve the issue?

  • Is the language for every administrator account set to either English or Japanese on the user account page? Oct 27 '20 at 8:26
  • @PatrickKenny Yes, the language is set to either English or Japanese.
    – Sergey
    Oct 28 '20 at 5:54

This can be changed on the Detection and selection page of the Language settings: /admin/config/regional/language/detection.

This page lists the detection methods, and by default, Drupal 8/9 prioritizes the path.

But, here you have two options.

Option 1: You can enable User (Follow the user's language preference) and then drag User above Path, which should give the admin pages in the admin language. This is simple, but the drawback to this approach is that users on the site will see content based on the language set in their account, not the site, which may not be what you want.

Option 2: You can enabled Account administration pages and then drag Account administration pages above Path. This will create a new setting on the user account edit page to set the admin language, so you may have to check all the admin accounts and set the language appropriately. This approach is more complex than the first, but limits the change to admin content only, which is probably what you want.

  • Thank you very much for your help. I will try.
    – Sergey
    Oct 29 '20 at 2:04
  • I tried the second approach but it seems that Account administration pages is being ignored. Probably another modules or patches cause such behavior. I will continue the investigation.
    – Sergey
    Oct 29 '20 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.