0

I am currently trying to upgrade my site from drupal 8.9 to drupal 9. I ran these commands to give permissions:

$ chmod 777 web/sites/default
$ find web/sites/default -name "*settings.php" -exec chmod 777 {} \;
$ find web/sites/default -name "*services.yml" -exec chmod 777 {} \;

Then I required the the recommended project for drupal 9 and also the dev:

$ composer require drupal/core-recommended:^9.0.0 drupal/core-composer-scaffold:^9.0.0 drupal/core-project-message:^9.0.0 --update-with-dependencies --no-update
$ composer require drupal/core-dev:^9.0.0 --dev --update-with-dependencies --no-update

All my modules are up to date and I also ran upgrade status to check for errors. I got one error, which was in tests (I guess that would be OK?) and a couple of warnings for a library that wasn't installed.

Then I ran

$ composer update

and got the following errors:

Problem 1
- drupal/core-recommended 9.0.7 requires drupal/core 9.0.7 -> satisfiable by drupal/core[9.0.7].
- Conclusion: don't install drupal/core 9.0.7
- drupal/core-recommended 9.0.6 requires drupal/core 9.0.6 -> satisfiable by drupal/core[9.0.6].
- Conclusion: don't install drupal/core 9.0.6
- drupal/core-recommended 9.0.5 requires drupal/core 9.0.5 -> satisfiable by drupal/core[9.0.5].
- Conclusion: don't install drupal/core 9.0.5
- drupal/core-recommended 9.0.4 requires drupal/core 9.0.4 -> satisfiable by drupal/core[9.0.4].
- Conclusion: don't install drupal/core 9.0.4
- drupal/core-recommended 9.0.3 requires drupal/core 9.0.3 -> satisfiable by drupal/core[9.0.3].
- Conclusion: don't install drupal/core 9.0.3
- drupal/core-recommended 9.0.2 requires drupal/core 9.0.2 -> satisfiable by drupal/core[9.0.2].
- Conclusion: don't install drupal/core 9.0.2
- drupal/core-recommended 9.0.1 requires drupal/core 9.0.1 -> satisfiable by drupal/core[9.0.1].
- Conclusion: don't install drupal/core 9.0.1
- drupal/core-recommended 9.0.0 requires drupal/core 9.0.0 -> satisfiable by drupal/core[9.0.0].
- Conclusion: don't install drupal/core 9.0.0
- drupal/core-recommended 9.0.0-rc1 requires drupal/core 9.0.0-rc1 -> satisfiable by drupal/core[9.0.0-rc1].
- Conclusion: don't install drupal/core 9.0.0-rc1
- drupal/core-recommended 9.0.0-beta3 requires drupal/core 9.0.0-beta3 -> satisfiable by drupal/core[9.0.0-beta3].
- Conclusion: don't install drupal/core 9.0.0-beta3
- drupal/core-recommended 9.1.0-alpha1 requires drupal/core 9.1.0-alpha1 -> satisfiable by drupal/core[9.1.0-alpha1].
- Conclusion: don't install drupal/core 9.1.0-alpha1
- drupal/core-recommended 9.2.x-dev requires drupal/core 9.2.x-dev -> satisfiable by drupal/core[9.2.x-dev].
- Conclusion: don't install drupal/core 9.2.x-dev
- drupal/core-recommended 9.1.x-dev requires drupal/core 9.1.x-dev -> satisfiable by drupal/core[9.1.x-dev].
- Conclusion: don't install drupal/core 9.1.x-dev
- drupal/core-recommended 9.0.x-dev requires drupal/core 9.0.x-dev -> satisfiable by drupal/core[9.0.x-dev].
- Conclusion: don't install drupal/core 9.0.x-dev
- drupal/core-recommended 9.0.0-beta2 requires drupal/core 9.0.0-beta2 -> satisfiable by drupal/core[9.0.0-beta2].
- Conclusion: don't install drupal/core 9.0.0-beta2
- drupal/core-recommended 9.0.0-beta1 requires drupal/core 9.0.0-beta1 -> satisfiable by drupal/core[9.0.0-beta1].
- Conclusion: don't install drupal/core 9.0.0-beta1
- drupal/core-recommended 9.0.0-alpha2 requires drupal/core 9.0.0-alpha2 -> satisfiable by drupal/core[9.0.0-alpha2].
- Conclusion: don't install drupal/core 9.0.0-alpha2- drupal/core-recommended 9.0.0-alpha1 requires drupal/core 9.0.0-alpha1 -> satisfiable by drupal/core[9.0.0-alpha1].
- Installation request for drupal/core-recommended ^9.0.0 -> satisfiable by drupal/core-recommended[9.0.0, 9.0.0-alpha1, 9.0.0-alpha2, 9.0.0-beta1, 9.0.0-beta2, 9.0.0-beta3, 9.0.0-rc1, 9.0.1, 9.0.2, 9.0.3, 9.0.4, 9.0.5, 9.0.6, 9.0.7, 9.0.x-dev, 9.1.0-alpha1, 9.1.x-dev, 9.2.x-dev].
- Installation request for drupal/upgrade_status ^2.11 -> satisfiable by drupal/upgrade_status[2.x-dev, 2.11.0].

My composer.json file looks like this:

{
"name": "name",
"description": "decription",
"type": "project",
"license": "",
"authors": [
    {
        "name": "",
        "role": ""
    }
],
"repositories": [
    {
        "type": "composer",
        "url": "https://packages.drupal.org/8"
    }
],
"require": {
    "composer/installers": "^1.7",
    "cweagans/composer-patches": "^1.6",
    "drupal/admin_toolbar": "^2.0",
    "drupal/console": "^1.0.2",
    "drupal/core-composer-scaffold": "^9.0.0",
    "drupal/core-project-message": "^9.0.0",
    "drupal/core-recommended": "^9.0.0",
    "drupal/paragraphs": "^1.2",
    "drupal/paragraphs_edit": "^2.0@alpha",
    "drush/drush": "^10",
    "j7mbo/twitter-api-php": "^1.0",
    "vlucas/phpdotenv": "^2.4",
    "webflo/drupal-finder": "^1.0.0",
    "webmozart/path-util": "^2.3"
},
"require-dev": {
    "drupal/core-dev": "^9.0.0",
    "drupal/upgrade_status": "^2.11"
},
"conflict": {
    "drupal/drupal": "*"
},
"minimum-stability": "dev",
"prefer-stable": true,
"config": {
    "sort-packages": true
},
"autoload": {
    "classmap": [
        "scripts/composer/ScriptHandler.php"
    ]
},
"scripts": {
    "drupal-scaffold": "DrupalComposer\\DrupalScaffold\\Plugin::scaffold",
    "pre-install-cmd": [
        "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
    ],
    "pre-update-cmd": [
        "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
    ],
    "post-install-cmd": [
        "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
    ],
    "post-update-cmd": [
        "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
    ]
},
"extra": {
    "drupal-scaffold": {
        "locations": {
            "web-root": "web/"
        }
    },
    "installer-paths": {
        "web/core": ["type:drupal-core"],
        "web/libraries/{$name}": ["type:drupal-library"],
        "web/modules/contrib/{$name}": ["type:drupal-module"],
        "web/profiles/contrib/{$name}": ["type:drupal-profile"],
        "web/themes/contrib/{$name}": ["type:drupal-theme"],
        "drush/contrib/{$name}": ["type:drupal-drush"]
    }
}

}

1
  • Please keep the error output and composer.json included in your question body. – leymannx Oct 28 '20 at 12:34
3

Remove drupal/console (composer remove drupal/console); it doesnt work on Drupal 9 yet, and it can break composer updates.

If it still doesn't work, delete the /vendor directory and composer.lock, then try running composer update again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy