3

I'm trying to apply the security update for core by updating it to 8.9.10 with the following command:

composer update drupal/core

But this only brings back the following notice:

Nothing to install or update

What am I doing wrong? How can I update core to 8.9.10?

3
  • 2
    Can you maybe add your composer.json to your question? Is it maybe drupal/core-recommended? Did you also try composer update drupal/core drupal/core-dev --with-dependencies?
    – leymannx
    Nov 26 '20 at 9:15
  • composer update drupal/core drupal/core-dev --with-dependenciesdid the trick... thank you very much. I did not update the composer.json to require drupal/core-recommended, it still required drupal/core - will need to change that Nov 26 '20 at 10:09
6

Thanks to @leymannx

composer update drupal/core drupal/core-dev --with-dependencies

did it

1
  • 3
    Correct, and if you ever have trouble finding out what blocks an update for core, then you can run composer prohibits drupal/core:8.9.10 in this particular case.
    – baikho
    Nov 26 '20 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.