0

I am trying to use Feeds to import/update content types, but it appears that it's not recognizing my mapping as I keep getting the error Integrity constraint violation: 1048 Column 'title' cannot be null.

I have a test CSV header like this

O*NET-SOC Code,Delete,Title - Arabic,Title - English,Priority of Tasks,Task ID,Task - English,Task - Arabic,Task Type,Incumbents Responding,Date,Domain Source

We are using the Task ID (column 6) as our Title, so in the mapping I did the following:

enter image description here

The target Title is suppose to be mapped to the CSV header Task ID, but I get the title cannot be null error with this row whose Task ID is 1014:

11-3131.00,Delete,<arabic text>,Training and Development Managers,3,1014,"Plan, develop, and provide training and staff development programs, using knowledge of the effectiveness of methods such as classroom training, demonstrations, on-the-job training, meetings, conferences, and workshops.",<arabic text>.,Core,27,07/2017,Occupational Expert

However, this csv row, whose Task ID is 1009 uploads without that error. :

11-3131.00,Delete,<arabic text>,Training and Development Managers,2,1009,"Evaluate instructor performance and the effectiveness of training programs, providing recommendations for improvement.",<arabic text>,Core,27,07/2017,Occupational Expert

What could cause the row with Task ID 1014 fail but the row with Task ID 1009 work without error?

NOTE: The question editor told me Arabic text isn't allowed, so I changed the Arabic text with in the CSV rows

11
  • Is the Arabic text the same for each row? Try doing each row with empty string instead of Arabic text and see if the same issue occurs. The best thing to do to debug this is to create the simplest row you can that still breaks. – mbomb007 Dec 17 '20 at 17:49
  • The arabic text is not the same, it's the translated version of their English counter-parts. However, I went ahead and tried to remove the Arabic text and left them as blank and I received the same error. – BlondeSwan Dec 17 '20 at 17:52
  • Try taking the row that works, and change the ID from 1009 to 1014. Then does it still work? – mbomb007 Dec 17 '20 at 17:53
  • Doing that made that row fail, – BlondeSwan Dec 17 '20 at 18:01
  • Then it appears the problem is not with the row itself, but with the ID number, somehow. I suggest looking at the code for where the error message comes from, and putting in some debug messages (like dpm()) for sanity checks – mbomb007 Dec 17 '20 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.