3

I have been working on a site, that allows users to submit encryption algorithms, for other users to test and/or crack them.

The problem I am having is in the text editor that I want to use to do this with. Being that I am now very used to, and comfortable with the Stack Exchange Markdown, I wanted to make my site use the same thing.

What I tried, was downloading the Markdown filter module, along with the Markdown Editor for BUEditor and Google Code Prettify modules.

I have been playing around with it for a little while, trying to configure it, and I noticed that there are several problems, that I can't figure out how to solve.

  1. Block quotes don't work: When attempting to make a block quote, instead of making it correctly, it just looks like > this is pseudo block quote text.
    Is there a library that I need to / can install to get this to work?

  2. Google prettify is working, but not coloring the code.
    Basically, I can get prettify to make the code look like this:

    public static void main (String[] args) {  
      System.out.println("this is a test example");  
    }
    

    It is not highlighted.

    public static void main (String[] args) {
      System.out.println("this is a test example");
    }
    

What am I doing wrong? Is this just a simple css issue? Is it something bigger? Should I use a different module entirely, and if so, which one? (I am using omega as my default theme. You can see an example of this that I created for debugging purposes here.)

(Note: This is not a question about a module bug, I am wondering if there is something that I have forgotten to set up, or am doing wrong, not the module itself.)

4

I'm getting a 403 forbidden on your prettify.js. If you change the permissions of the sites/all/libraries/prettify/src folder to 777, It should solve your problem.

  • I changed the permissions for now, you should be able to look at the file – Ephraim May 2 '12 at 23:24
  • It seems to work right now?! – JohannesM May 2 '12 at 23:25
  • Yeah, I just realized that. In setting the permissions 777, that doing so is what solved the problem. I guess drupal was unable to read the file with the current permissions. I think you just solved my problem by accident! :D Although, can you figure out why the block quotes on markdown aren't working – Ephraim May 3 '12 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.