1

I am getting WSOD just in homepage and the hardest part is it is not giving any clue of what is the error. Tried to check the error log but there is no error. Tried also to add this in the index.php

error_reporting(E_ALL);
ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);

But the above code didn't help. Viewing the source code in the browser gives me...

<html>
<head></head>
<body>
</body>
</html>

The weird thing is when I restarted memcached the problem go away. But this happen regularly like when I restarted Memcache after 3 days problem return so I need to restart the Memcache and other caching.

Additional details of the site:

  1. Homepage is mostly Views
  2. I'm using Memcache and Boost
  3. Context
  • 1
    What changed just prior to the onset of WSODs? A new module installed, enabled or disabled? Do you perform regular database and code backups and if so can you revert? Are all your modules current? Try the command example.com/update.php in the URL. IF something is not properly synchronized between your database and code, that command should help synchronize things. – Ashlar May 2 '12 at 3:53
  • Hi Ashlar, I always run update.php via drush updb. I suspect my problem is related to this post drupal.org/node/496198#comment-1720400 – ninjascorner May 3 '12 at 5:15
  • Reading that post, I'm relieved to see it is another simple DrupaL problem! :) – Ashlar May 3 '12 at 18:04
1

Try adding this to your settings.php file (not index.php). After you see what error message you have we might be able to help you better. Usually WSOD are caused by a PHP fatal error.

error_reporting(-1);
$conf['error_level'] = 2;
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

Source: Show all errors while developing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.