2

I'm working on a website which has multiple admins, some creating contents, some editing and some tagging...

I know editing one node at the same time will cause this error, is there anything else cause this error?

The content on this page has either been modified by another user, or you have already submitted modifications using this form. As a result, your changes cannot be saved.

closed as too broad by kiamlaluno Nov 9 '17 at 7:49

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I'll take a wild guess, maybe it could be caused by Revisions. When 2 admins start editing same revision, then one saves it, goes OK, the other tries to save it after, but the revision he started editing is already out of date. – Beebee May 2 '12 at 10:06
  • Is there any way to disable edit links for second admin while there is an open edit form? – Mohammad Ali Akbari May 2 '12 at 10:12
  • 2
    A bit late but yes, drupal.org/project/content_lock allows to lock nodes which are currently being edited. – Berdir Jun 1 '12 at 19:37
  • not late, its an open question for me, yet. tnx – Mohammad Ali Akbari Jun 2 '12 at 6:44
  • Related: drupal.stackexchange.com/questions/163331/… – leymannx Sep 15 '17 at 16:00
2

Another cause might me the fact that you save a form, then hit the back button and try to save it again

  • Yes this case already mentioned in error ...or you have already submitted modifications using this form..., do you think is any other case? – Mohammad Ali Akbari May 3 '12 at 4:58
1

I just managed to create this error with a FireFox setting. I told FF never to save history and cleared my browser cache and then could not submit changes to nodes. When I turned 'save history' back on, the issue resolved. Probably related to a change in how FF was handling cookies.

Site is Drupal 7 with OpenPublish, IDK much more than that as I'm new to the project.

0

I got this error across my entire site and I'm not sure of the root cause.

If I edited and saved a page and then clicked the edit tab to edit the page and tried to save again, I would get the error.

I was banging my head against the wall trying to fix it until I fixed it by rebuilding the site permissions: admin/reports/status/rebuild

Another solution that others pointed to was to increase the max_input_vars in your php.ini file.

0

If the problem is related to two users editing the same record (node), it can be related to max_input_vars in your php.ini

There are two solutions to solve the problem (I recommend trying both of them):

  1. Edit phpi.ini and increase max_input_vars (find max_input_vars = ... and increase it). php.ini can be found in different locations for example in an ubuntu conventional setup it can be at /etc/php5/apache2/php.ini
  2. Clear cache (depend on your browser this is a pretty easy routine and you already do not know it, just google it).

Check https://www.drupal.org/node/1933120

0

It may be due to Maximum Input Variable Limit. You can use a module to control it. PHP Runtime Configurator module provides many options to configure without changing your php.ini file and restart Apache.

You can configure following parameters:

  • File Upload Limit
  • Memory Limit
  • Maximum Execution Time Limit
  • Maximum Input Variable Limit

Not the answer you're looking for? Browse other questions tagged or ask your own question.