1

I am using paragraphs on a multilingual Drupal 9 page. Everything is working fine, I can translate basic pages with paragraphs to get a multilingual node.

I have now enabled the Paragraphs Library sub module, but I can't enable the language support for that.

  • When creating a new paragraph library item at /admin/content/paragraphs/add/default there is no language selector. Library items are always in the page's default language: English. Add Paragraphs library item without language selector
  • In the "Paragraphs library item settings - Manage form display" the default field "Language" with the widget "Language select" is present. (/admin/config/content/paragraphs_library_item/form-display) Manage form display with langauge field
  • In "Configuration - Regional and language" at /admin/config/regional/content-language there is a check box for "Paragraphs library item". If I tick this checkbox and save the page, it reloads and the tick is gone. I'm not able to enable "Paragraphs library item" in "Custom language settings" here. I do not get any error in the "Recent log messages" either. Content language settings
  • Below on this same page (/admin/config/regional/content-language) there is the default paragraph type entry "From library". I have enabled this like I did with my other paragraphs. Paragraph Type From library

What am I missing to enable language support for paragraphs library items? Thank you for you help and suggestions in advance!

2
  • I'm in the same boat right now. Did you figure this out?
    – Randell
    May 18, 2021 at 4:43
  • No, I made a workaround. I have solved this by creating a new custom content type called "Paragraph Library", containing only one unlimited paragraph field "field_predefined_paragraph"; ticking the paragraph types you want. Reuseable content can be saved as a new node in the content type "Paragraph Library", which contains paragraphs. Of course I also created a new paragraph type "Paragraph Library" containing one Entity Reference field field_reuseable_paragraph, ticking only the content type "Paragraph Library". Now you can add your reuseable content using the paragraph "Paragraph Library".
    – matzn.eda
    May 19, 2021 at 15:03

1 Answer 1

0

I had the same issue but I solved it the following way:

  • Make sure to tick "Paragraphs library item" in "Custom language settings" section
  • After that, scroll down (without saving) to the section "Paragraphs library item" and tick "Paragraphs library item" + fields to be translated.
  • Save your settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.