0

We have several sites running with Drupal.
On my local machine I run the test versions of each site in the Docker container to add new features or test new ones.

When switching between pages I do the following.
Shut down the container of page-A.
Change to the directory of page-B, start the container.
Then execute the following commands in the terminal in the container:

composer clearcache
composer install
drush sql-drop --yes; 
drush sqlc < page-B_init.sql
drush updb
drush cim

When running drush cim, the following error message appears:

 [error]  Drupal\Core\Config\ConfigImporterException: There were errors validating the config synchronization.
Entity type mismatch on rename.  not equal to configurable_language for existing configuration system.site and staged configuration language.entity.en.
Rename operation for simple configuration. Existing configuration system.site and staged configuration language.entity.en. in Drupal\Core\Config\ConfigImporter->validate() (line 755 of /var/www/html/docroot/core/lib/Drupal/Core/Config/ConfigImporter.php).

In ConfigImportCommands.php line 261:

  The import failed due to the following reasons:
  Entity type mismatch on rename.  not equal to configurable_language for existing configuration system.site and staged configuration language.entity.en.
  Rename operation for simple configuration. Existing configuration system.site and staged configuration language.entity.en.

I suspect the problem is with the UUID, which I have in the files:

environments/_default/config/sync/system.site.yml
environments/_default/config/sync/language.entity.en.yml

adapted.
But I don't know any further.
Does anyone have an idea where the error lies?

Use Drupal 8.9.13

0

This might not be the best way, but I had this same issue today. I ended up renaming language.entity.en.yml to include .OLD at the end of the filename for a backup, then I re-ran drush cim. After that it accepted my system.site.yml file. Then I took a look at the language.entity.en.yml file and for some reason it had the exact same UUID as the system.site file. I suspect the import is confused about which file is which because they both had the same UUID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.