0

Possible Duplicate:
Content not showing when logged out!

I don't understand why this is happening. When logged in everything is fine but when logged out some blocks like slideshow and some views go missing. What's annoying is that I have two jCarousel slideshows on my page and only one of them disappears after logout.

I've checked the user permissions and I don't find any anomalies there. Can anyone please suggest why this could be happening?

5
  • 1
    Did you check the permissions on the blocks themselves? May 4, 2012 at 13:24
  • 1
    Yes I've checked the user roles for each of those missing blocks and everything seems to be fine. I even put a check on all three user roles in blocks configuration but it remains the same. This was fine before and happened all of a sudden. May 5, 2012 at 5:10
  • You can try checking the permissions for the Views as well. Unfortunately, you also have to check permissions for all of the content displayed in the views. Do you have a backup of when things were working well? If you can compare a working version with a non-working version, you might be able to find the solution quicker... May 5, 2012 at 5:25
  • 1
    I've checked permissions on views as well and still no luck. I don't have a backup of working things so that's out of question. How do I check permissions on all the contents? By the way I remember this happened when I was working on the taxonomy problem in views and it was fine before that. Can there be some connection with this? May 8, 2012 at 7:19
  • I am closing this, as the new question includes this question.
    – apaderno
    May 12, 2012 at 9:49

0

Browse other questions tagged or ask your own question.