I am trying to uninstall the modules that are part of the Relation module, after I tested it on my test site.

The Relation Endpoints Field module is not selectable because Drupal says the field implemented by that module is being used.


When I click on the "Field list" link, I get the following list of fields currently used.


None of the reported fields is implemented by that module; they are standard Drupal fields.

What should I do, in such cases? The content type that used that field has been already deleted.


This happened to me with a couple of modules last week; the solution was simply to run cron, allowing the fields marked for deletion to actually be deleted. After that I could uninstall the module in question without issue.

  • 5
    I had to run the cron tasks more than once, after I uninstalled the modules depending from that module, and it worked. When the link changed to, "fields pending deletion" the cron tasks deleted the fields, and I was able to uninstall the module.
    – apaderno
    May 4 '12 at 22:19
  • Thanks! I ran into this problem trying to uninstall the Registration module. I also had to run cron 2 or 3 times before it actually deleted the field I wanted to delete.
    – octern
    Aug 29 '12 at 18:50
  • I can't seem to find any fields related to the module and I didn't see anything in the database to indicate that at all. Does anyone have any other ideas?
    – Patrick
    Nov 2 '12 at 4:42
  • 1
    Ok, after checking on it again I found that I had installed the Dummy Field module. I had to uninstall it. Then uninstall the rest of the relation modules. After that I was able to disable the relation endpoints module.
    – Patrick
    Nov 2 '12 at 4:46
  • 1
    It's important uninstall the depending modules first (Relation, Relation UI, etc), before running cron multiple times. Mar 18 '13 at 23:30

Had same issue right now with Getlocations modules. I solved this uninstalling disabled modules "admin/modules/uninstall/"

Hope this helps


If you have access to phpMyAdmin for the site in question, the easiest way to solve this problem is to run the following query:

DELETE FROM field_config WHERE field_config.deleted = 1;

This is a problem caused by "fields pending deletion" in one of the core tables. Even after the field is deleted from all content types using the field, it isn't dropped from the field_config table properly.

Some people suggest running cron "an arbitrary number of times" or waiting "an arbitrary period of time" but neither of these seems to work consistently or have a defined number. The only reliable solution I've found thus far is to run the query above when needed.

As soon as that query has been executed, you will be able to disable the module and uninstall as desired.

Hope this helps. Here are some additional links if anyone wants to read more about this: https://github.com/backdrop/backdrop-issues/issues/82 https://technonaturalist.net/comment/1167#comment-1167

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.