1

I recently upgraded from Drupal 8 to Drupal 9. I've used drush config-split:export (drush csex) quite often. After the upgrade, it keeps throwing an error which is very vague.

Not enough arguments (missing: "split")

No documentation says what the problem is, nor what that argument should be.

Any help would be much appreciated.

3
  • 3
    You can just run drush config:export. Very old versions required explicitly calling a config split – Jaypan Mar 30 at 3:21
  • 1
    Isn't it just missing the split's name? Like drush config-split:export MYSPLIT? Run drush help config-split:export. – leymannx Mar 30 at 7:22
  • 1
    The example of usage for the command is drush config-split:export development, which is said to Export configuration of the "development" split. – kiamlaluno Mar 30 at 8:36
0

In order to use config-split:export with Drupal 9, make sure you go to admin/config/development/configuration/config-split. There you should see if you already have a split configuration and use machine name: drush config-split:export [machine_name]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.