I am using a view with a "content:link" field to display a custom link for each content in my block.

I have job listing in block and want to add a link for each job "Apply". When users click on "Apply" it will redirect to a webform with title of the respective job.

So in my View under the REWRITE RESULTS setting I have selected Rewrite the output of this field and added my custom anchor tag like below:

 <a href='20?id=[title]'>Apply Now</a>

It works but it's putting title with anchor tag. So the output URL becomes

 <a href='20?id=<a href="mysite/node/23">Team leader</a>'>Apply Now</a>

Here I want the value of title token, without an anchor tag. Is it possible? Or any other way to do this job?

1 Answer 1


I solved this issue. As described below :

We can use fields as token only whose we selected a block field.

I have selected title as block field with link to content node. so it was taking title anchor as token. I have removed tick for "Link to node" option from title field settings.

Now it's working fine.

  • yea, you have to uncheck the "Link to Node" option or else it will always generate an A-tag fragment. Glad you figured it out.
    – tenken
    Jun 24, 2013 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.