1

I'm currently running a CentOS 7 server with cPanel and Drupal 8. I installed Solr 8.8.1 and I can access the administratrion page where I an able to create cores. I installed the Search API module with Composer.

When I try to use the Solr server via the Search API module, I get a server connection error.

I tried a lot of Drupal configuration, with Basic Auth and standard, via localhost, IP and domain name, but I'm still not able to connect to the Solr server.

Everything I do gets me the following error.

The Solr server could not be reached or is protected by your service provider.

I am the service provider. I verified the firewall isn't blocking the connection.

Can someone tell me what I could have done wrong?

5
  • Firstly, you have to choose right version seach solr api. As you said, you need to choose version 4.1.
    – MrD
    Jun 9 at 0:25
  • Hello, i'm currently using the 4.1.12 version of Search API Solr
    – Tom Tom
    Jun 9 at 8:07
  • That's the module or the actual version of Solr?
    – Kevin
    Jun 9 at 16:56
  • Hello, the version of Solr is mentionned in the original post: 8.8.1
    – Tom Tom
    Jun 10 at 7:19
  • 1
    CentOS may have SELinux enabled by default. See wiki.centos.org/HowTos/SELinux for troubleshooting. Jul 6 at 18:46
0

@hotwebmatter's answer above helped me with this issue, so I'll add instructions:

  1. Check the status of SELinux: getenforce. In my case, the status was enabled, so I needed to disable it.
  2. Disable SELinux: sudo nano /etc/selinux/config, then change SELINUX=enabled to SELINUX=disabled.
  3. Reboot: systemctl reboot

Check the status of your Solr server again at /admin/config/search/search-api/server/scs_solr.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.