0

I just updated from Drupal 8.9.16 to Drupal 9.2.0. It worked fine in my test environment, but when I try on the production environment, I get the following error.

requires the 'core' key not be set in core/profiles/testing_install_profile_dependencies_bc/testing_install_profile_dependencies_bc.info.yml

I have looked in the core directory and do not have this path, so I am not sure why it is complaining about it. Googling, I saw this was part of Drupal 8.8.

Is the content of YAML files stored in the database somewhere?

I am stuck with a site that displays a WSOD. I am hoping someone else has come across this issue and can help me fix it.

These are the first lines of the stack trace.

Drupal\Core\Extension\InfoParser->parse('core/profiles/testing_install_profile_dependencies_bc/testing_install_profile_dependencies_bc.info.yml') (Line: 554)
Drupal\Core\Extension\ExtensionList->createExtensionInfo(Object) (Line: 316)
Drupal\Core\Extension\ExtensionList->doList() (Line: 282)
Drupal\Core\Extension\ExtensionList->getList() (Line: 125)
Drupal\Core\Extension\ModuleExtensionList->getActiveProfile() (Line: 90)
Drupal\Core\Extension\ModuleExtensionList->getExtensionDiscovery() (Line: 298)
Drupal\Core\Extension\ExtensionList->doScanExtensions() (Line: 137)
Drupal\Core\Extension\ModuleExtensionList->doScanExtensions() (Line: 312)
Drupal\Core\Extension\ExtensionList->doList() (Line: 154)
Drupal\Core\Extension\ModuleExtensionList->doList() (Line: 282)
Drupal\Core\Extension\ExtensionList->getList() (Line: 260)
Drupal\Core\Extension\ExtensionList->get('ctools') (Line: 243)
Drupal\Core\Extension\ExtensionList->getName('ctools') (Line: 712)
Drupal\Core\Extension\ModuleHandler->getName('ctools') (Line: 52)
Drupal\Core\Block\BlockManager->getProviderName('ctools') (Line: 34)
Drupal\Core\Block\BlockManager->processDefinitionCategory(Array) (Line: 67)
Drupal\Core\Block\BlockManager->processDefinition(Array, 'entity_view:block') (Line: 286)
Drupal\Core\Plugin\DefaultPluginManager->findDefinitions() (Line: 175)
Drupal\Core\Plugin\DefaultPluginManager->getDefinitions() (Line: 22)

2
  • 1
    Yes module discovery is stored in active config in the DB - have you cleared the cache?
    – Clive
    Jun 17, 2021 at 13:00
  • Yes I have. When I try to clear the cache it is when it throws the error you see above. I have dropped all the tables and reloaded them, and still get the error. I guess I need to find where this is in the database and remove it manually but don't know where that is.
    – user5013
    Jun 17, 2021 at 15:32

1 Answer 1

1

It should be in the cache_default bin, keyed as core.extension.list.module. However, are you sure that you're using the database cache in the production environment? If you're using memcached or redis instead, the database cache tables would just be sitting there vestigially, pretending to do work.

1
  • as, by the way, am I
    – Les Lim
    Jun 17, 2021 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.