1

I have fought for some time with the error below:

Non-translatable field elements can only be changed when updating the original language.

I have "inherited" a site a few years ago and been updating it so it's D8 up-to-date (8.9.16).

When the user tries to save a change in language version of a page (on many but not all pages), she gets the aforementioned error message (even if not changing anything on the form).

After researching the problem a bit I found out about the module: Remove Entity Untranslatable Field Validation. I installed it and it made its magic going through the pages but the problem just didn't go away after that.

Other than that there's not much help in the web and I am running out of options, does anyone here have any suggestions what to try next?

4
  • 1
    Perhaps going to "admin/config/regional/content-language" and checking "Hide non translatable fields on translation forms" option for your contents might help.
    – misterdidi
    Jun 30, 2021 at 7:56
  • Thank you, unfortunately all those are already checked. Should have (and thought to but forgot) mentioned that in the question
    – hank
    Jun 30, 2021 at 7:59
  • This is crucial for the question, but checking could cause the issue, not unchecking. Also important is the information which fields are configured non-translatable. Not all fields should be and there is still an open issue with multi-property widgets. See drupal.org/project/drupal/issues/3026055
    – 4uk4
    Jun 30, 2021 at 8:18
  • 1
    Ok, unchecking the boxes really solved the problem. I still feel that wording makes me think just the other way round, but who cares when it works :) Thank you
    – hank
    Jun 30, 2021 at 9:36

4 Answers 4

3

I had the same issue.

Solution:

  • Goto /admin/config/regional/content-language
  • then check CONFIGURATION "Hide non translatable fields on translation forms"
  • if it's still happening then check TRANSLATABLE (* unsupported) fields.

Solved.

2

This issue may be related to your problem. https://www.drupal.org/project/entity_reference_revisions/issues/3150084

0

Unchecking all "Hide non translatable fields on translation forms"-boxes in Content language-configuration page solved the problem.

0

I had the same problem. I fixed it by going to /admin/config/regional/content-language looking for the content type and enabling the translation for the published field. I think that the module workflow was trying to set a specific value for that field in the translated node and that caused the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.