0

I use the module Meta Tags for adding meta data to my nodes. And it works like a charm. It's super easy to add meta tages like title, keywords, description,... even our IT-noob marketing team can do so. It's awesome.

However, not all content types seems to be able to save those meta data. I've got 12 content types and 3 of them don't display the meta data. Although I add them like on the other nodes...

Here is the source code of a node without any meta:

enter image description here

And here with meta:

enter image description here

So correct me if I'm wrong, but I don't see any meta data in the first example.

Strange part, all the data is present in the database (table metatag), so all nodes does save the meta data, but for some reason, some content types aren't displaying the meta data.

What could be the cause of this "bug". Could it be something like hiding certain content in the template files since they all have a separate .tpl.php file? Or what other causes are you thinking of?

1

There is an issue with the module.

Try the following code in node.tpl.php.

render($content['metatags']);

Alternatively, try with the following code in page.tpl.php.

print render($page['content']['metatags']); 
  • Ok, great! This helped me a lot! Thanks a million!! – Michiel May 9 '12 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.