1

The "Upgrade Status" module reports that "Commerce Base" exists in site file structure, but is not installed and suggests removing it. I expect that the Commerce project references those files to work, but I don't know.

Should this project in my composer/json 'requires' list be removed using Composer? "drupalcommerce/commerce_base": "dev-8.x-1.x",

Remove listing in Upgrade Status module report

My original Drupal 8 install was with Composer using: composer create-project drupalcommerce/project-base XXXXXX --stability dev

I presently have Commerce 8.x-2.26 installed.

I'd like to upgrade to from Drupal 8.9.x to 9.2.x.

Thank you for any advice!

2
  • It's used by the project-base package, so probably listed directly in your own composer.json? If so and it's uninstalled, should be safe to remove
    – Clive
    Aug 26, 2021 at 14:43
  • I tried to remove drupalcommerce/commerce_base project but then get a white screen of death when vistiing a commerce page : The website encountered an unexpected error. Please try again later. So I think I need to get a newer version of commerce_base ? Aug 26, 2021 at 20:34

1 Answer 1

1

There was a bug in upgrade_status that didn't treat profiles (like drupalcommerce/project-base ) as they should be. But instead treated it like a misbehaving module.

This is fixed in this issue: https://www.drupal.org/project/upgrade_status/issues/3230266

So you can try the patch from that issue, or wait for a new release which includes the patch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.