1

I installed Easy breadcrumb module and added Breadcrumbs block to my Block Layout. However, I can not make breadcrumbs appear on the front page. Block settings do not contain any that specify block display/hide on a specific pages. I have breadcrumbs on all other pages.

I am using a subtheme of Tara theme but I have no hooks that affect breadcrumbs. I have custom modules but they do not do anything to breadcrumbs.

I have checked the settings of Easy Breadcrumb and everything looks fine.

Hide link to home page if it's the only breadcrumb item

This setting is OFF.

Can it be that the source of the problem is the front page path settings? Via Basic Site Settings it is set to /front, while all links to the front are actually just /.

Any help and assumptions will be appreciated.

2
  • What are you expecting for a breadcrumb?
    – sonfd
    Aug 28 '21 at 19:14
  • @sonfd Thank you for reply. I just want that "Home" text will be shown without any link attached to it.
    – Sergey
    Aug 29 '21 at 3:07
1

In cases like this, it's often not worth spending any time trying to debug why a contributed module isn't behaving as expected, because the workaround is so simple.

The Block you want to see on the front page will always contain the same markup, so it does not need to be dynamically generated.

Copy the desired markup from another page that has the breadcrumbs, and place this markup in a custom Block.

It should be easy to create the desired Block either programmatically (with a very simple custom module) or via the Drupal UI. Make sure to edit the markup to remove the link from the word Home, and to remove any other breadcrumbs that follow.

Then place that block in the desired theme region, and set it to appear only on the front page.

1
  • Thank you for the advice. I somehow managed to fix the problem by editing twig templates and it seems to work fine now.
    – Sergey
    Sep 3 '21 at 3:00
-3

On visibility settings in block edit page, - >pages -> select all pages except listed - > and set in bellow text box - > < front > without space

1
  • Unfortunately this setting hides breadcrumbs on all pages, thank you for advice.
    – Sergey
    Aug 29 '21 at 3:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.