I have a default install of Drupal 7 with the Tokens module. I'm using [current-page:title] in a node body, but the content isn't being replaced.

I've looked for settings and at the Token module page, and nothing. What am I missing?

  • Have you cleared the cache? Commented May 9, 2012 at 6:19
  • 2
    The Tokens module doesn't replace tokens on node bodies. Do you have a module that is supposed to do that?
    – apaderno
    Commented May 9, 2012 at 8:52

1 Answer 1


As @kiamlaluno mentioned in the comment, neither the token API in core nor the token.module replaces tokens in node bodies.

For that, you need a module like Token Filter.

  • 2
    And you have to select the checkbox Replace Tokens in admin/config/content/formats after the module is installed.
    – kylex
    Commented May 10, 2012 at 1:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.