1

I am trying to set up a multilingual web site, in English and Spanish. The way I want to setup the web site is:

www.example.com: main page of the site in Spanish

www.example.com/en: main page in English

and

www.example.com/productos/ejemplodeproducto: Spanish product page

www.example.com/en/products/exampleproduct: English product page

Instead, for the Spanish pages, there is always a prefix as well:

www.example.com/es/productos/ejemplodeproducto: Spanish product page

Is it possible to not have a language prefix in the URL for the main language? That's how our site worked with Wordpress. We are using Drupal 7.

4

Yes, just go to 'admin/config/regional/language', click the edit link of your main language (Spanish), delete the prefix and save your changes.

If you have issues (like links still having the old prefix in them) then clear the caches ('admin/config/development/performance').

  • That 'sort of' works. The problem is that, when you're in Spanish mode, all the admin menu links at the top are broken. For example example.com/es/admin/config/content results in a page not found error. – SomethingBetter May 10 '12 at 19:27
  • Those links shouldn't have that 'es' in them. Tried clearing the caches to see if that resolves the issue? – Madis May 10 '12 at 20:37
  • I'm afraid they don't go away. I tried a different computer and a different browser. Moreover, when in spanish mode, if I click an administration link, it goes to: example.com/en/es/admin/config/search/settings . Very weird. – SomethingBetter May 10 '12 at 20:51
  • I meant the site cache (under 'admin/config/development/performance') - in case it wasn't clear. – Madis May 10 '12 at 21:08
  • Glad it didn't turn out to be a bug :) – Madis May 12 '12 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.