-4

I tried to set up my drupal 8 full project on localhost but after set up when I run project getting error as shown below:-

The website encountered an unexpected error. Please try again later.

Drupal\Component\Plugin\Exception\PluginNotFoundException: The "node" entity type does not exist. in Drupal\Core\Entity\EntityTypeManager->getDefinition() (line 150 of core\lib\Drupal\Core\Entity\EntityTypeManager.php). Drupal\Core\Entity\EntityTypeManager->getHandler('node', 'storage') (Line: 208) Drupal\Core\Entity\EntityTypeManager->getStorage('node') (Line: 187) Drupal\Core\Entity\EntityRepository->getCanonicalMultiple('node', Array, Array) (Line: 180) Drupal\Core\Entity\EntityRepository->getCanonical('node', '1', Array) (Line: 149) Drupal\Core\ParamConverter\EntityConverter->convert('1', Array, 'node', Array) (Line: 100) Drupal\Core\ParamConverter\ParamConverterManager->convert(Array) (Line: 45) Drupal\Core\Routing\Enhancer\ParamConversionEnhancer->enhance(Array, Object) (Line: 260) Drupal\Core\Routing\Router->applyRouteEnhancers(Array, Object) (Line: 131) Drupal\Core\Routing\Router->matchRequest(Object) (Line: 92) Drupal\Core\Routing\AccessAwareRouter->matchRequest(Object) (Line: 113) Symfony\Component\HttpKernel\EventListener\RouterListener->onKernelRequest(Object, 'kernel.request', Object) call_user_func(Array, Object, 'kernel.request', Object) (Line: 111) Drupal\Component\EventDispatcher\ContainerAwareEventDispatcher->dispatch('kernel.request', Object) (Line: 127) Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object, 1) (Line: 68) Symfony\Component\HttpKernel\HttpKernel->handle(Object, 1, 1) (Line: 57) Drupal\Core\StackMiddleware\Session->handle(Object, 1, 1) (Line: 47) Drupal\Core\StackMiddleware\KernelPreHandle->handle(Object, 1, 1) (Line: 47) Drupal\Core\StackMiddleware\ReverseProxyMiddleware->handle(Object, 1, 1) (Line: 52) Drupal\Core\StackMiddleware\NegotiationMiddleware->handle(Object, 1, 1) (Line: 23) Stack\StackedHttpKernel->handle(Object, 1, 1) (Line: 708) Drupal\Core\DrupalKernel->handle(Object) (Line: 20)

1
  • Welcome to Drupal Answers! 👋 Please always add the steps to reproduce an issue. Like: how did you setup the site exactly? What OS? How do you access the site? What URL? What version of PHP/Composer and so on. Many thanks
    – leymannx
    Sep 16 '21 at 18:57
1

If the "node" entity type does not exist, you have a fundamentally broken installation, but it's not possible to say exactly how it's broken based on the information given.

There are a couple things I would inspect at this point:

  • Is your local database complete? Did the import perhaps fail?
  • Is the cache out-of-date? Try truncating every database table with a name that starts with cache_, or if you have Drush, running drush cr

Not the answer you're looking for? Browse other questions tagged or ask your own question.